Project

General

Profile

feature request #7439

Use NatTable for BulkEditor

Added by Patrick Plitzner 7 months ago. Updated 3 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
05/28/2018
Due date:
% Done:

100%

Severity:
normal

Description

Use NatTable composite for displaying the information in the bulk editor instead of the current SWT table viewer.

For example code look at CharacterMatrix class

picture998-1.png View (7.63 KB) Andreas Müller, 06/15/2018 09:00 PM

picture257-1.png View (22.2 KB) Andreas Müller, 06/20/2018 10:31 AM

picture970-1.png View (12.3 KB) Andreas Müller, 06/20/2018 10:37 AM

picture942-1.png View (6.85 KB) Andreas Müller, 06/26/2018 11:58 AM


Related issues

Related to Edit - feature request #6321: Implement parallel loading + progress bar for loading objects into the bulk editor Closed 01/10/2017
Related to Edit - bug #7484: Protected titleCache handling not correct in Reference detail view Closed 06/15/2018
Related to Edit - feature request #7485: Use tree table for reference and author bulk editor New 06/15/2018
Related to Edit - feature request #7506: Allow direct editing bulk editor Duplicate 06/21/2018
Related to Edit - feature request #7507: Advanced "Copy" in bulk editor New 06/21/2018
Precedes Edit - feature request #7502: Add further columns to bulk editor Closed 05/29/2018
Precedes Edit - feature request #7503: Make cells in bulk editor editable New 05/30/2018
Copied to Edit - feature request #7518: remaining issues for usage of NatTable for bulkeditor Closed 06/27/2018

Associated revisions

Revision f6f03fa3 (diff)
Added by Patrick Plitzner 7 months ago

ref #7439 Show titleCache in NatTable in bulk editors

Revision 378fbb8a (diff)
Added by Patrick Plitzner 7 months ago

ref #7439 Show titleCache and type in NatTable in bulk editors

Revision 94d71120 (diff)
Added by Patrick Plitzner 7 months ago

ref #7439 Extract column property accessor to class

Revision bf128d5f (diff)
Added by Patrick Plitzner 7 months ago

ref #7439 Add e4 context menu to nattable

  • add full row selection

Revision 8309769f (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Propagate row selection of nattable

Revision 97352439 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Move event list to editor input

Revision 72614023 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Fix visual update when converting team <> person

Revision 0354dac6 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Adapt label when selecting merge target/candidates

Revision d9b8df42 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Add "Copy" to context menu

  • show context menu for empty editor when clicking on header

Revision 0fb37c99 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Show context menu for empty editor when clicking on corner

Revision e4ebff17 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Remove jface viewer related code

Revision 029aa66a (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Add sorting and cell text left-align to bulk editor nat table

Revision a1b92e88 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Remove sort type combo box

Revision 0acc65d5 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Update marker change in supplemental view

Revision 7106e8d1 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Fixc initial sort of bulk editor list

Revision 31a9124b (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Cleanup saveCandidates of bulk editor input

Revision ede4ba36 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 set dirty flag to false when closing bulkeditor

  • code cleanup

Revision f6fe3908 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Update entity in bulk editor when editing details

Revision 2674f1d5 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 little refactoring

Revision 32b90a5c (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Fix potential NPE

Revision 8dc339f5 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Scroll to selection when editing elements

Revision e3492ca9 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Make cells editabel to allow selecting text

Revision 6cf49987 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Re-select after search has finished

Revision abe4eec5 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Re-select after entity has been loaded

Revision 0ceb7d55 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Fix rare rendering problem during initialization

Revision 1e037cd6 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 SQLize title search for occurrences

Revision af09c490 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 i18n for "copy" command

Revision 21e30f05 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 auto resize columns after search

Revision 73d25c5b (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Fix loading progress of occurrence bulk editor

Revision 01a4599b (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 increase size of id column

Revision 9d6458e9 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 disable auto-resize after search

Revision a4784593 (diff)
Added by Patrick Plitzner 6 months ago

ref #7439 Add context menu to cell editor, disable editing

Revision ceac293a (diff)
Added by Katja Luther 6 months ago

revert edit of text in bulkeditor and resize of columns

Revision 63a2e46c (diff)
Added by Patrick Plitzner 5 months ago

ref #7439 Code refactoring

Revision 96e043f8 (diff)
Added by Patrick Plitzner 5 months ago

ref #7439 Split BulkEditorE4 in E4 part and Composite

  • clean up code

History

#1 Updated by Katja Luther 6 months ago

the selection as candidate or target is not possible, the menu items are not enabled.
and the details view does not show up.
the menu items are not correct, for example there are menu items like "change to person" for references

#2 Updated by Andreas Müller 6 months ago

  • Status changed from New to In Progress
  • Target version changed from Unassigned CDM tickets to Release 5.1

#3 Updated by Patrick Plitzner 6 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 0 to 50

#4 Updated by Katja Luther 6 months ago

  • Status changed from Resolved to Feedback

this works fine now

maybe one minor issue: when set a multi selection as deduplication candidate, the marker is not shown before changing the selection, this is a little bit confusing.

#5 Updated by Katja Luther 6 months ago

  • Assignee changed from Katja Luther to Andreas Müller

#6 Updated by Patrick Plitzner 6 months ago

Katja Luther wrote:

this works fine now

maybe one minor issue: when set a multi selection as deduptlication candidate, the marker is not shown before changing the selection, this is a little bit confusing.

This works for me. I select two elements, right-click "Set as candidate" and the marker appears in the label

#7 Updated by Andreas Müller 6 months ago

Can we have left alignment instead of center alignment. Especially for the titleCache columns this is easier to read.

#8 Updated by Andreas Müller 6 months ago

  • Related to feature request #6321: Implement parallel loading + progress bar for loading objects into the bulk editor added

#9 Updated by Andreas Müller 6 months ago

For focus loss after save see #6321#note-23

#10 Updated by Andreas Müller 6 months ago

  • Related to bug #7484: Protected titleCache handling not correct in Reference detail view added

#11 Updated by Andreas Müller 6 months ago

Critical: sometimes the table does not show up after opening a bulk editor.

Even after "search" the table does not show up. Only re-sizing helps. Something users may not know.
Reproduction is difficult but for me always worked when opening at least 3 name bulk editors without doing anything else in between.

Also the details view is not emptied when the new bulk editor is opened (see attachment)

#12 Updated by Andreas Müller 6 months ago

Can we remove the "Sort by" field (see attachment above)? It think it is not in use in all/most bulk editors.

Instead it would be nice and very helpful to enable sorting by columns in the NAT tables.
And of course it would be nice to allow more columns such as further cache fields,id, uuid, created, updated,... which can also be used for sorting (but this might be a new ticket)

#13 Updated by Andreas Müller 6 months ago

Adding a marker does not update the "+" in supplemental data view. Maybe this is not related to NAT.

#14 Updated by Andreas Müller 6 months ago

Copying parts of the titleCache within the table is not possible. This is a regression compared to the old table.

Can we make cells "editable" in the sense that it is possible to select (and copy) parts of the text but at same time not make it possible to change data in the field? This is how it was before.

#15 Updated by Andreas Müller 6 months ago

Copying always copies the titlecache column value even if the other column has the focus. For now this might be acceptable as we have only one important column but may change once we have multiple columns with information that users may want to copy.
This may become irrelevant once the above issue #7439#note-14 is implemented.

#16 Updated by Andreas Müller 6 months ago

If the whole row has the focus we may want to copy all fields in csv or tsv format.

#17 Updated by Andreas Müller 6 months ago

"Copy" is not yet translated to German.

#18 Updated by Andreas Müller 6 months ago

For multi-select copy is not yet possible but might be a very nice feature (e.g. for copy and paste larger datasets to Excel). Feel free to create a new ticket as this is a new feature.

#19 Updated by Andreas Müller 6 months ago

#20 Updated by Patrick Plitzner 6 months ago

Comment #7439#note-7: Cell text is left aligned
Comment #7439#note-11: I can reproduce this as well when opening the third editor. Question: Do we really want to allow opening the same type of bulk editor multiple times?
Comment #7439#note-12: Enabled sorting (Please open a new ticket specifying which additional columns should be present)
Comment #7439#note-13: Could not reproduce this behavior. Which bulk editor did you use? On which element did you test this?

#21 Updated by Andreas Müller 6 months ago

Patrick Plitzner wrote:

Comment #7439#note-11: I can reproduce this as well when opening the third editor. Question: Do we really want to allow opening the same type of bulk editor multiple times?

Sure. Searching for "B*" is different from "A*". One may want to have open both for various reasons.

#22 Updated by Andreas Müller 6 months ago

Also the problem is not necessarily related to opening multiple editors. But this is how you can easily reproduce the behavior.

#23 Updated by Andreas Müller 6 months ago

Patrick Plitzner wrote:

Comment #7439#note-13: Could not reproduce this behavior. Which bulk editor did you use? On which element did you test this?

No matter which bulk editor. Just take any name, taxon, reference or author (...) without a marker => no + shows up in supplemental data view beside marker.
Add a marker via bulk editor. Still no + shows up (but should).

#24 Updated by Andreas Müller 6 months ago

#25 Updated by Andreas Müller 6 months ago

Andreas Müller wrote:

Copying parts of the titleCache within the table is not possible. This is a regression compared to the old table.

Can we make cells "editable" in the sense that it is possible to select (and copy) parts of the text but at same time not make it possible to change data in the field? This is how it was before.

By the way, changing data within the columns may become an option now. E.g. changing the specific epithet of a name might be more comfortable to do within the table then within the details view as the workflow is probably faster if you go through a long list of names.
It was no option as long as only the titleCache was shown. Editing the titleCache should still only be possible if the cache is protected (same as in details view). Should we open a new ticket for editing fields (this is also related to #7502)

#26 Updated by Andreas Müller 6 months ago

#27 Updated by Andreas Müller 6 months ago

Andreas Müller wrote:

For multi-select copy is not yet possible but might be a very nice feature (E.g. for copy and paste larger datasets to Excel). Feel free to create a new ticket as this is a new feature.

By the way, it might be nice to have a simple "copy" operation and an advanced "copy ..." which then allow setting further configuration to the copy command, like format (csv, tsv, ...), include header, NULL value handling, etc.
HeidiSQL has a nice configuration dialog:

Feel free to create new ticket.

#28 Updated by Andreas Müller 6 months ago

Patrick Plitzner wrote:

Comment #7439#note-7: Cell text is left aligned

Great! Looks much better now.

One more possible improvement: after first search, can we adapt column width to the percentage of the longest text that occurs per columns (or some similar algorithm that tries to optimize the column width. Now, we get something like

which is less functional.

Feel free to create new ticket if not trivial. Also dependend on #7502.

#29 Updated by Andreas Müller 6 months ago

Patrick Plitzner wrote:

Comment #7439#note-12: Enabled sorting (Please open a new ticket specifying which additional columns should be present)

Great! But there is a problem now. If sorting is e.g. DESC on titleCache, reloading (#6321) should take place in the same order.

#30 Updated by Patrick Plitzner 6 months ago

Comment #7439#note-9: Focus loss is fixed
Comment #7439#note-11: Rendering problem is fixed
Comment #7439#note-12: Removed sort combo
Comment #7439#note-14: Cell text can be selected but not edited
Comment #7439#note-16: new ticket #7507
Comment #7439#note-17: i18n for "copy"
Comment #7439#note-18: new ticket #7507
Comment #7439#note-23: This is fixed but other issue occured (#7504)
Comment #7439#note-25: new ticket #7506

#31 Updated by Patrick Plitzner 6 months ago

#32 Updated by Patrick Plitzner 6 months ago

#33 Updated by Patrick Plitzner 6 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

Andreas Müller wrote:

Patrick Plitzner wrote:

Comment #7439#note-12: Enabled sorting (Please open a new ticket specifying which additional columns should be present)

Great! But there is a problem now. If sorting is e.g. DESC on titleCache, reloading (#6321) should take place in the same order.

The problem is, that the initial search is sorted in the cdmlib service method. When clicking on the header in the nattable the search is done on the local list of results. If this sort order is changed to DESC and we would do a re-search with also DESC on the cdmlib side we would get a descending order first which would then be sorted again in the local list leading to ASC.
Maybe we can ignore this issue because it will be resolved when we avoid doing the re-search after save.

#34 Updated by Andreas Müller 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

#36 Updated by Andreas Müller 6 months ago

Having the markers for deduplication (target, candidate) in the text fields is not very comfortable and scalable. When we have multiple columns and users change the order of the columns the order gets lost. Also editing the columns (#7503) will not be possible anymore.
Is there no other possibility to add markers rows in NAT tables? If not we should create a new column which then handles the deduplication information seperately (preferably with a 3 state icon - none, target, candidate).

#37 Updated by Andreas Müller 6 months ago

Using the standard right click menu is cumbersome as clicking on a column cell immediately changes the cell into the editing mode with a less comfortable menu:

We had the same discussion when introducing the standard tables for bulk editor. Please refer to that discussion for details. Generally we need to go to editing mode only by double click. And even better we should not show the above menu in editing mode but a more suitable one.

This is release critical.

#38 Updated by Andreas Müller 6 months ago

Changing the text in a cell for now should not be possible until #7503 is implemented. If NAT tables don't offer such a state we could probably catch the change events and handle them such that the text does not change.

#39 Updated by Andreas Müller 6 months ago

Andreas Müller wrote:

Having the markers for deduplication (target, candidate) in the text fields is not very comfortable and scalable. When we have multiple columns and users change the order of the columns the order gets lost. Also editing the columns (#7503) will not be possible anymore.
Is there no other possibility to add markers rows in NAT tables? If not we should create a new column which then handles the deduplication information seperately (preferably with a 3 state icon - none, target, candidate).

We decided to use row colors instead. Additionally offering tooltips saying that a row is target or candidate for deduplication.

#42 Updated by Andreas Müller 6 months ago

Andreas Müller wrote:

Using the standard right click menu is cumbersome as clicking on a column cell immediately changes the cell into the editing mode with a less comfortable menu:

We had the same discussion when introducing the standard tables for bulk editor. Please refer to that discussion for details. Generally we need to go to editing mode only by double click. And even better we should not show the above menu in editing mode but a more suitable one.

This is release critical.

Now, the editing mode shows the standard menu but in many cases no menu appears at all when doing some kind of right click on the table. This is very critical. Maybe we better revert everything related to editing mode.

#43 Updated by Andreas Müller 6 months ago

Now, column resizing is disabled which is better then before. However, we should resize the table to window size at the beginning when opening the bulk editor.

#44 Updated by Katja Luther 6 months ago

The editing mode of the table caused a widget is disposed exception and no menu was shown.
I reverted these changes and the resizing.

#45 Updated by Katja Luther 6 months ago

#46 Updated by Katja Luther 6 months ago

  • Status changed from Feedback to Closed

close this ticket and created a new one with remaining issues (#7518)

#47 Updated by Andreas Müller 4 months ago

#48 Updated by Andreas Müller 4 months ago

#49 Updated by Andreas Müller 3 months ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)