Project

General

Profile

bug #7399

Adding taxon nodes to working sets leads to MultipleRepresentationException

Added by Patrick Plitzner 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
05/04/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

Steps to reproduce:

  1. Create a working set
  2. Add a taxon node to it
  3. Save
  4. Close WS editor and Re-Connect
  5. Open working set in WS editor
  6. Add another node from the same classification -> exception

Associated revisions

Revision a92e923a (diff)
Added by Patrick Plitzner 7 months ago

fix #7399 Fix multiRepException when adding taxon nodes

  • used remoteLoad() of CdmEntitySession

History

#1 Updated by Patrick Plitzner 7 months ago

  • Status changed from New to Feedback
  • Assignee changed from Patrick Plitzner to Andreas Müller

For testing purpose I removed @Cascade({CascadeType.SAVE_UPDATE,CascadeType.MERGE}) from Set<TaxonNode> taxonSubtreeFilter in the WorkingSet model class and the problem was fixed.
Is cascading necessary here?

#2 Updated by Andreas Müller 7 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

we may think about removing the Cascade as it is probably not necessary. However, a multiple-representations exception is usually a hint that something is not done correctly somewhere so I would prefer to first understand why the problem occurs and fix it and then remove Cascade.

#3 Updated by Andreas Müller 7 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.0

#4 Updated by Patrick Plitzner 7 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 50

#5 Updated by Patrick Plitzner 7 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 0

#6 Updated by Patrick Plitzner 7 months ago

  • % Done changed from 0 to 50

#7 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

As you have detected the issue and know the background you can probably best decide if you think this ticket is fixed.

Feel free to close when you think the issue is fully fixed.

#8 Updated by Patrick Plitzner 7 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)