Project

General

Profile

Actions

bug #7391

closed

grant UPDATE for taxonnames temporarily when using a name as basionym

Added by Andreas Kohlbecker almost 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Highest
Category:
cdm-vaadin
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Severity:
critical
Found in Version:
Tags:

Description

see #7390

Temporarily grant the UPDATE authority to the user performing the operations in the client application. Grant before flushing the session and remove the grant afterwards. Use a try-catch-finally clause where the withdrawal of the temporary permission is done in the finally clause.


Related issues

Related to EDIT - bug #7390: possible permission clash when adding basionymDuplicateAndreas Müller

Actions
Related to EDIT - bug #7392: Remove Cascade from relationsClosedAndreas Müller

Actions
Actions #1

Updated by Andreas Kohlbecker almost 5 years ago

  • Related to bug #7390: possible permission clash when adding basionym added
Actions #2

Updated by Andreas Müller almost 5 years ago

Can this also be closed after #7392 has been fixed?

Actions #3

Updated by Andreas Müller almost 5 years ago

  • Related to bug #7392: Remove Cascade from relations added
Actions #4

Updated by Andreas Kohlbecker almost 5 years ago

  • Status changed from New to Rejected
  • Target version deleted (Release 5.0)

since the cause for #7390 is a different one than originally assumed the solution requested by this issue here become invalid and we can close the issue.

Actions

Also available in: Atom PDF