Project

General

Profile

bug #7387

TaxonNamePopEditor: ConstraintViolationException on saving a basionym

Added by Andreas Kohlbecker 8 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
04/27/2018
Due date:
% Done:

0%

Severity:
major
Found in Version:
Tags:

Description

Akzeptierter Name mit Basionym (neu) einer bisher nicht vorhandenen Publikation mit einem bisher nicht vorhandenen Autor.

Der Speicherfehler tritt dann immer beim Abspeichern des Basionyms auf.

Caused by: org.hibernate.exception.ConstraintViolationException: could not execute statement
                    at org.hibernate.exception.internal.SQLExceptionTypeDelegate.convert(SQLExceptionTypeDelegate.java:59)
                    at org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:42)
                    at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:109)
                    at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:95)
                    at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:207)
                    at org.hibernate.engine.jdbc.batch.internal.NonBatchingBatch.addToBatch(NonBatchingBatch.java:45)
                    at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2886)
                    at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:3386)
                    at org.hibernate.action.internal.EntityInsertAction.execute(EntityInsertAction.java:89)
                    at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:560)
                    at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:434)
                    at org.hibernate.event.internal.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:337)
                    at org.hibernate.event.internal.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:39)
                    at org.hibernate.internal.SessionImpl.flush(SessionImpl.java:1282)
                    at org.hibernate.internal.SessionImpl.managedFlush(SessionImpl.java:465)
                    at org.hibernate.internal.SessionImpl.flushBeforeTransactionCompletion(SessionImpl.java:2963)
                    at org.hibernate.internal.SessionImpl.beforeTransactionCompletion(SessionImpl.java:2339)
                    at org.hibernate.engine.jdbc.internal.JdbcCoordinatorImpl.beforeTransactionCompletion(JdbcCoordinatorImpl.java:485)
                    at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl.beforeCompletionCallback(JdbcResourceLocalTransactionCoordinatorImpl.java:147)
                    at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl.access$100(JdbcResourceLocalTransactionCoordinatorImpl.java:38)
                    at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl$TransactionDriverControlImpl.commit(JdbcResourceLocalTransactionCoordinatorImpl.java:231)
                    at org.hibernate.engine.transaction.internal.TransactionImpl.commit(TransactionImpl.java:65)
                    at org.springframework.orm.hibernate5.HibernateTransactionManager.doCommit(HibernateTransactionManager.java:581)
                    ... 98 more
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Duplicate entry 'f30e0552-929c-4390-b292-e422e7f3d7af' for key 'UK_l3pp0mset9oltk84pnvytx215'
                    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
                    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
                    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
                    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
                    at com.mysql.jdbc.Util.handleNewInstance(Util.java:404)
                    at com.mysql.jdbc.Util.getInstance(Util.java:387)
                    at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:932)
                    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3878)
                    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3814)
                    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2478)
                    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2625)
                    at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2551)
                    at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:1861)
                    at com.mysql.jdbc.PreparedStatement.executeUpdateInternal(PreparedStatement.java:2073)
                    at com.mysql.jdbc.PreparedStatement.executeUpdateInternal(PreparedStatement.java:2009)
                    at com.mysql.jdbc.PreparedStatement.executeLargeUpdate(PreparedStatement.java:5094)
                    at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:1994)
                    at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeUpdate(NewProxyPreparedStatement.java:384)
                    at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:204)
                    ... 116 more

Related issues

Related to Edit - bug #7386: TaxonNamePopEditor: com.vaadin.data.Property$ReadOnlyException on saving a basionym Resolved 04/27/2018

History

#1 Updated by Andreas Kohlbecker 8 months ago

The violated contrained UK_l3pp0mset9oltk84pnvytx215 in the stackstace above is the Unique contraint for the TaxonName.uuid

#2 Updated by Andreas Kohlbecker 8 months ago

  • Related to bug #7386: TaxonNamePopEditor: com.vaadin.data.Property$ReadOnlyException on saving a basionym added

#3 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from New to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

this has apparently been solved by fixing #7386.

Hening can you reproduce this issue? Otherwise we can close it as duplicate of #7386

#4 Updated by Wolf-Henning Kusber 5 months ago

  • Status changed from Feedback to Worksforme

#5 Updated by Wolf-Henning Kusber 5 months ago

  • Status changed from Worksforme to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)