Project

General

Profile

Actions

bug #7342

closed

incomplete bean initialization with specific data causes LIEs

Added by Katja Luther about 4 years ago. Updated 7 months ago.

Status:
Worksforme
Priority:
Highest
Category:
cdmlib-remote
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Severity:
critical
Found in Version:
Tags:

Description

this has been observed at the salvador portal where a lot of functionality is broken due to LazyInitializationException which happen lately:

potentially a duplicate of #7331 yet unconfirmed

  • does not return data for search
  • opening the taxa returns "Taxon does not exist"
  • expand ANGIOSPERMAE in the taxontree does not work, expand GYMNOSPERMAE works, but the children can not be expanded

affected web service calls with the resulting LazyInitializationException

http://api.cybertaxonomy.org/salvador/portal/taxon/find.json?doTaxaByCommonNames=0&doMisappliedNames=0&doSynonyms=0&doTaxa=1&pageNumber=0&pageSize=25&query=A*

Caused by: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.agent.Team.teamMembers, could not initialize proxy - no Session
    at org.hibernate.collection.internal.AbstractPersistentCollection.throwLazyInitializationException(AbstractPersistentCollection.java:567)
    at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:205)
    at org.hibernate.collection.internal.AbstractPersistentCollection.initialize(AbstractPersistentCollection.java:546)
    at org.hibernate.collection.internal.AbstractPersistentCollection.read(AbstractPersistentCollection.java:133)
    at org.hibernate.collection.internal.PersistentList.iterator(PersistentList.java:132)
    at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getNomenclaturalTitle(TeamDefaultCacheStrategy.java:83)
    at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getNomenclaturalTitle(TeamDefaultCacheStrategy.java:1)
    at eu.etaxonomy.cdm.model.agent.Team.getNomenclaturalTitle(Team.java:261)
    at sun.reflect.GeneratedMethodAccessor7586.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.invoke(JavassistLazyInitializer.java:79)
    at eu.etaxonomy.cdm.model.agent.TeamOrPersonBase_$$_jvst73e_61.getNomenclaturalTitle(TeamOrPersonBase_$$_jvst73e_61.java)
    at eu.etaxonomy.cdm.strategy.cache.name.TaxonNameDefaultCacheStrategy.getAuthorAndExAuthor(TaxonNameDefaultCacheStrategy.java:260)
    at eu.etaxonomy.cdm.strategy.cache.name.TaxonNameDefaultCacheStrategy.getNonCacheAuthorshipCache(TaxonNameDefaultCacheStrategy.java:202)
    at eu.etaxonomy.cdm.strategy.cache.name.TaxonNameDefaultCacheStrategy.getAuthorshipCache(TaxonNameDefaultCacheStrategy.java:176)
    at eu.etaxonomy.cdm.strategy.cache.name.TaxonNameDefaultCacheStrategy.getTaggedTitle(TaxonNameDefaultCacheStrategy.java:413)
    at eu.etaxonomy.cdm.model.name.TaxonName.getTaggedName(TaxonName.java:1427)
    at eu.etaxonomy.cdm.remote.json.processor.bean.TaxonNameBeanProcessor.processBeanSecondStep(TaxonNameBeanProcessor.java:66)
    at eu.etaxonomy.cdm.remote.json.processor.bean.TaxonNameBeanProcessor.processBeanSecondStep(TaxonNameBeanProcessor.java:25)
    at eu.etaxonomy.cdm.remote.json.processor.bean.AbstractBeanProcessor.processBean(AbstractBeanProcessor.java:167)
    at net.sf.json.JSONObject._fromBean(JSONObject.java:676)

http://api.cybertaxonomy.org/salvador/portal/taxon/33b0cde7-a693-4dfd-a67d-b6ac52b78742/taxonNodes.json

Caused by: org.hibernate.LazyInitializationException: could not initialize proxy - no Session
    at org.hibernate.proxy.AbstractLazyInitializer.initialize(AbstractLazyInitializer.java:148)
    at org.hibernate.Hibernate.initialize(Hibernate.java:62)
    at eu.etaxonomy.cdm.hibernate.HibernateProxyHelper.deproxy(HibernateProxyHelper.java:58)
    at eu.etaxonomy.cdm.model.common.CdmBase.deproxy(CdmBase.java:306)
    at eu.etaxonomy.cdm.strategy.cache.taxon.TaxonBaseDefaultCacheStrategy.getNameTags(TaxonBaseDefaultCacheStrategy.java:95)
    at eu.etaxonomy.cdm.strategy.cache.taxon.TaxonBaseDefaultCacheStrategy.getTaggedTitle(TaxonBaseDefaultCacheStrategy.java:65)
    at eu.etaxonomy.cdm.model.taxon.TaxonBase.getTaggedTitle(TaxonBase.java:221)
    at eu.etaxonomy.cdm.remote.json.processor.bean.TaxonBaseBeanProcessor.processBeanSecondStep(TaxonBaseBeanProcessor.java:54)
    at eu.etaxonomy.cdm.remote.json.processor.bean.TaxonBaseBeanProcessor.processBeanSecondStep(TaxonBaseBeanProcessor.java:25)
    at eu.etaxonomy.cdm.remote.json.processor.bean.AbstractBeanProcessor.processBean(AbstractBeanProcessor.java:167)
    at net.sf.json.JSONObject._fromBean(JSONObject.java:676)

Files

salvador_portal_no_data.png (9.93 KB) salvador_portal_no_data.png Katja Luther, 04/04/2018 02:21 PM

Related issues

Related to EDIT - bug #7331: AdvancedBeanInitializer fails to initialize properties of preinitialized beans in the graph in very special situationsNewAndreas Müller

Actions
Actions #1

Updated by Katja Luther about 4 years ago

  • Description updated (diff)
Actions #2

Updated by Katja Luther about 4 years ago

for example portal/classification/b010c84d-6049-45f4-9f13-c065101eaa26/childNodesOf/a7d542c5-1ae2-4edd-9f46-445b9b7f6f0c fails with lazyLoadingException - no Session (all clicks for opening a taxon result in LazyInitiolisationExceptions)

clicking on ANGIOSPERMAE results in:

"This concept of the taxon ANGIOSPERMAE sec. Berendsohn & al. 2009-2016 is not contained as an accepted taxon in the currently chosen classification, but in this one: Nova Silva Cuscatlanica" but "Nova Silva Cuscatlanica" is the default classification and there is only one classification.

Actions #3

Updated by Katja Luther about 4 years ago

  • Related to bug #7331: AdvancedBeanInitializer fails to initialize properties of preinitialized beans in the graph in very special situations added
Actions #4

Updated by Andreas Kohlbecker about 4 years ago

  • Tags set to salvador
  • Subject changed from Salvador portal does not return data to incomplete bean initialization with specific data
  • Description updated (diff)
  • Category set to cdmlib-remote
Actions #5

Updated by Andreas Kohlbecker about 4 years ago

  • Description updated (diff)
Actions #6

Updated by Andreas Kohlbecker about 4 years ago

  • Description updated (diff)
Actions #7

Updated by Andreas Kohlbecker about 4 years ago

  • Subject changed from incomplete bean initialization with specific data to incomplete bean initialization with specific data causes LIEs

ich habe den cdm-server heute morgen um 2018-04-05 08:51:14 neu gestartet, weil der swap-space wieder mal sehr stark beansprucht war. Vorher hatte ich noch dieses Ticket um Stacktraces ergänzt. Seit dem ist das Problem anscheinen verschwunden.

Tritt das Problem möglicherweise dann auf, wenn der Server zu stark belastet ist?

Actions #8

Updated by Andreas Müller about 4 years ago

  • Target version changed from Release 5.0 to Release 5.1
Actions #9

Updated by Andreas Müller about 4 years ago

  • Target version changed from Release 5.1 to Release 5.2
Actions #10

Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 5.2 to Release 5.3
Actions #11

Updated by Katja Luther almost 4 years ago

  • Target version changed from Release 5.3 to Release 5.4
Actions #12

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.4 to Release 5.5
Actions #13

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.5 to Release 5.6
Actions #14

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.6 to Reviewed Next Major Release
Actions #15

Updated by Andreas Müller 8 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Kohlbecker
  • Target version changed from Reviewed Next Major Release to Release 5.34

As I can't reproduce any of the LIEs anymore I suggest to close this ticket as worksforme (and remove target version). Instead reopen new ticket if the problem occurs again.

Actions #16

Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Resolved to Worksforme
  • Target version deleted (Release 5.34)
Actions

Also available in: Atom PDF