Project

General

Profile

bug #7326

NPE when setting focus on specimen in Specimen Editor (hierarchy)

Added by Andreas Kohlbecker 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
03/22/2018
Due date:
% Done:

100%

Severity:
critical
Found in Version:

Description

Version: 4.15.0-SNAPSHOT Build Date: 2018-03-22 15:47 CET

I used the new Open in ... Specimen Editor context menu entry for GatheringEvents implemented in the ReferencingObjectsView. Setting the focus on the specimen with the mouse pointer raised the NPE posted below

login : admin
editor version : 4.15.0.201803221447
server : test.e-taxonomy.eu (edit-test) / phycobank
schema version : 4.7.0.0.201710040000
os : Linux 4.13.0-37-generic amd64
java : 1.8.0_131
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4536)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4154)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.NullPointerException
    at java.util.ArrayList.<init>(ArrayList.java:177)
    at eu.etaxonomy.taxeditor.ui.section.AbstractEntityCollectionSection.renderContent(AbstractEntityCollectionSection.java:219)
    at eu.etaxonomy.taxeditor.ui.section.AbstractEntityCollectionSection.internalUpdateSection(AbstractEntityCollectionSection.java:207)
    at eu.etaxonomy.taxeditor.ui.section.AbstractEntityCollectionSection.setEntity(AbstractEntityCollectionSection.java:165)
    at eu.etaxonomy.taxeditor.ui.section.occurrence.DeterminationDetailElement.createControls(DeterminationDetailElement.java:49)
    at eu.etaxonomy.taxeditor.ui.section.occurrence.DeterminationDetailElement.createControls(DeterminationDetailElement.java:1)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.updateContent(AbstractCdmDetailElement.java:107)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.setEntity(AbstractCdmDetailElement.java:94)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailSection.setEntity(AbstractCdmDetailSection.java:128)
    at eu.etaxonomy.taxeditor.view.detail.CdmSectionPart.setFormInput(CdmSectionPart.java:155)
    at org.eclipse.ui.forms.ManagedForm.setInput(ManagedForm.java:210)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.refresh(AbstractCdmDataViewerE4.java:156)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.setInput(AbstractCdmDataViewerE4.java:141)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsViewerE4.setInput(DetailsViewerE4.java:194)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4.showViewer(AbstractCdmEditorPartE4.java:213)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsPartE4.selectionChanged_internal(DetailsPartE4.java:104)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4$DelaySelection.run(AbstractCdmEditorPartE4.java:85)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 24 more

picture116-1.png View (88.4 KB) Andreas Kohlbecker, 03/22/2018 04:05 PM

Associated revisions

Revision 462c058e (diff)
Added by Patrick Plitzner 9 months ago

fix #7326 Fix potential NPE

History

#1 Updated by Andreas Kohlbecker 9 months ago

  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.0
  • Severity changed from normal to critical

This but can be reproduced independently of the ReferencingObjectsView and seems to happen with any Specimen! This must be fixedx before the release

#2 Updated by Andreas Müller 9 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

#3 Updated by Patrick Plitzner 9 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#4 Updated by Patrick Plitzner 9 months ago

  • Assignee changed from Patrick Plitzner to Andreas Kohlbecker

#5 Updated by Andreas Kohlbecker 9 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Kohlbecker to Patrick Plitzner
  • % Done changed from 50 to 100

it's fixed!

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)