Project

General

Profile

bug #7290

bug #6545: [MASTER] Eclipse 4 bugs

Creating the first node in a new polytomous key throws NPE

Added by Andreas Müller 10 months ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
02/22/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

  1. Create new PolytomousKey
  2. Create new PolytomousKeyNode -> Exception
login : admin
editor version : 4.15.0.201802211343
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.navigation.navigator.e4.TaxonNavigatorE4.updateSyncButton(TaxonNavigatorE4.java:196)
    at eu.etaxonomy.taxeditor.navigation.navigator.e4.TaxonNavigatorE4.refresh(TaxonNavigatorE4.java:283)
    at eu.etaxonomy.taxeditor.navigation.navigator.e4.TaxonNavigatorE4.onChange(TaxonNavigatorE4.java:492)
    at eu.etaxonomy.taxeditor.store.CdmUIDataChangeService$2.run(CdmUIDataChangeService.java:44)
    at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:233)
    at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:145)
    at org.eclipse.swt.widgets.Display.syncExec(Display.java:4821)
    at eu.etaxonomy.taxeditor.store.CdmUIDataChangeService.fireChangeEvent(CdmUIDataChangeService.java:41)
    at eu.etaxonomy.taxeditor.operation.RemotingCdmOperation.fireDataChangeEvent(RemotingCdmOperation.java:75)
    at eu.etaxonomy.taxeditor.operation.RemotingCdmDefaultOperation.postExecute(RemotingCdmDefaultOperation.java:49)
    at eu.etaxonomy.taxeditor.operation.RemotingCdmOperation.execute(RemotingCdmOperation.java:51)
    at eu.etaxonomy.taxeditor.model.AbstractUtility.lambda$4(AbstractUtility.java:197)
    at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
    at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 23 more

Associated revisions

Revision 4bf09483 (diff)
Added by Patrick Plitzner 10 months ago

fix #7290 Fix NPE when view has not already been created

History

#1 Updated by Andreas Müller 10 months ago

  • Description updated (diff)

#2 Updated by Andreas Müller 10 months ago

  • Parent task set to #6545

#3 Updated by Patrick Plitzner 10 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#4 Updated by Patrick Plitzner 10 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

#5 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner

Seems to be fixed

#6 Updated by Andreas Müller 7 months ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)