Project

General

Profile

bug #7187

ReferenceEditor: saving with DOI casues exception

Added by Andreas Kohlbecker 11 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
01/15/2018
Due date:
% Done:

50%

Severity:
normal
Found in Version:

Description

doi entered: 10.5507/for.2016.020

Exception:

Caused by: com.vaadin.data.util.converter.Converter$ConversionException: Could not convert value to DOI
    at com.vaadin.ui.AbstractField.convertToModel(AbstractField.java:775)
    at com.vaadin.ui.AbstractField.convertToModel(AbstractField.java:752)
    at com.vaadin.ui.AbstractField.getConvertedValue(AbstractField.java:838)
    at com.vaadin.ui.AbstractField.commit(AbstractField.java:253)
    ... 95 more
Caused by: com.vaadin.data.util.converter.Converter$ConversionException: Unable to convert value of type java.lang.String to model type class eu.etaxonomy.cdm.common.DOI. No converter is set and the types are not compatible.
    at com.vaadin.data.util.converter.ConverterUtil.convertToModel(ConverterUtil.java:182)
    at com.vaadin.ui.AbstractField.convertToModel(AbstractField.java:772)
    ... 98 more

Associated revisions

Revision 931fe3c9 (diff)
Added by Andreas Kohlbecker 11 months ago

fix #7187 adding converter for DOI and URI

History

#1 Updated by Andreas Kohlbecker 11 months ago

  • Status changed from New to In Progress

#2 Updated by Andreas Kohlbecker 11 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker 11 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 50 to 0

ist repariert, bitte teste ob es für dich funktiniert (ab 16.1.2018)

#4 Updated by Andreas Kohlbecker 3 months ago

  • % Done changed from 0 to 50

bitte review

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)