Project

General

Profile

bug #7146

ClassCastException when clicking on synchronize button

Added by Katja Luther 12 months ago. Updated 12 months ago.

Status:
Closed
Priority:
Priority14
Assignee:
Category:
taxeditor
Target version:
Start date:
12/21/2017
Due date:
% Done:

0%

Severity:
normal
Found in Version:

Description

I just clicked on l"link with taxon" option and received this error
no taxon was selected or searched

login : m.malekmohammadi
editor version : 4.12.1
server : api.cybertaxonomy.org (cybertaxonomy.org) / caryophyllales_spp
schema version : 4.7.0.0.201710040000
os : Windows 7 6.1 amd64
java : 1.8.0_151
org.eclipse.e4.core.di.InjectionException: java.lang.ClassCastException: eu.etaxonomy.taxeditor.view.e4.details.DetailsPartE4 cannot be cast to eu.etaxonomy.taxeditor.navigation.navigator.e4.TaxonNavigatorE4
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.ClassCastException: eu.etaxonomy.taxeditor.view.e4.details.DetailsPartE4 cannot be cast to eu.etaxonomy.taxeditor.navigation.navigator.e4.TaxonNavigatorE4
at eu.etaxonomy.taxeditor.navigation.navigator.e4.handler.LinkWithTaxonHandlerE4.execute(LinkWithTaxonHandlerE4.java:32)
at sun.reflect.GeneratedMethodAccessor152.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
... 36 more

Associated revisions

Revision abc3e4c9 (diff)
Added by Katja Luther 12 months ago

ref #7146: avoid classCastException

History

#1 Updated by Katja Luther 12 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Patrick Plitzner
  • Target version changed from Unassigned CDM tickets to Release 4.13

can not reproduce the exception, normally it should not happen, because the canExecute check for the right Class, but now there is a second instanceof check in execute method.

#2 Updated by Katja Luther 12 months ago

  • Subject changed from CassCastException when clicking on synchronize button to ClassCastException when clicking on synchronize button

#3 Updated by Patrick Plitzner 12 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Patrick Plitzner to Katja Luther

seems good

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)