Project

General

Profile

bug #7143

Finish not enabled when unprotecting titleCache in new Person dialog

Added by Andreas Müller almost 2 years ago. Updated 15 days ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
12/19/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

Using the new person dialog, at the beginning the title cache is protected. Therefore entering data e.g. into "family name" does not change the titleCache. It is still empty and therefore the "Finish" button is still disabled.

Now clicking on unprotected fills the titleCache and therefore the Finish button should be enabled, but isn't.

Please check if this might also be the case for other "New" dialogs.

picture465-1.png View (25.2 KB) Andreas Kohlbecker, 11/06/2019 03:53 PM

Associated revisions

Revision 4e34a1f2 (diff)
Added by Katja Luther almost 2 years ago

ref #7143: enable finish in create person dialog if titleCache is set

Revision 788e46eb (diff)
Added by Katja Luther 24 days ago

ref #7143: enable finish correctly when titlecache is set

Revision 2cace77b (diff)
Added by Katja Luther 16 days ago

ref #7143: fix activation of finish button

History

#1 Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)

#2 Updated by Andreas Kohlbecker about 1 month ago

The problem persists, even if a commit exists for this issue.

#3 Updated by Andreas Müller 28 days ago

  • Status changed from New to In Progress
  • Target version changed from Unassigned CDM tickets to Release 5.11

Katja can you check the state here.

But we need to be very careful. I remember this has been fixed once but the fix created a regression elsewhere. So it needs to be well checked.

#4 Updated by Katja Luther 24 days ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Kohlbecker

now it should work correctly, please review

#5 Updated by Katja Luther 24 days ago

  • % Done changed from 0 to 70

#6 Updated by Andreas Kohlbecker 18 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Kohlbecker to Katja Luther
  • Found in Version set to Release 5.10

Finish is not enabled when only the title cache is filled with data.

Even after entering the family name it still is required to click the title cache padlock icon twice to turn the Finish button to enabled state.

#7 Updated by Katja Luther 17 days ago

  • Assignee changed from Katja Luther to Andreas Kohlbecker

Andreas Kohlbecker wrote:

Finish is not enabled when only the title cache is filled with data.

Even after entering the family name it still is required to click the title cache padlock icon twice to turn the Finish button to enabled state.

With the actual nightly I cannot reproduce this problem anymore. Did you used the actual nightly build?

#8 Updated by Andreas Kohlbecker 17 days ago

  • Status changed from Feedback to Resolved

Katja Luther wrote:

Andreas Kohlbecker wrote:

With the actual nightly I cannot reproduce this problem anymore. Did you used the actual nightly build?

I was testing with the nightly build from yesterday. I will test again today.

#9 Updated by Andreas Kohlbecker 16 days ago

I would expect that the finish button is enabled after entering text in the TitleCache field only.

This is not yet working:

#10 Updated by Katja Luther 15 days ago

  • Assignee changed from Katja Luther to Andreas Kohlbecker

this is fixed now.

#11 Updated by Andreas Kohlbecker 15 days ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Kohlbecker to Katja Luther
  • Priority changed from New to Highest
  • % Done changed from 70 to 100

confirmed!

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)