Project

General

Profile

Actions

bug #7136

closed

after deduplication of persons the referencing teams still pointing to the deleted persons

Added by Katja Luther over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Highest
Category:
taxeditor
Target version:
-
Start date:
Due date:
% Done:

50%

Estimated time:
Severity:
normal
Found in Version:

Description

Beim Deduplizieren eines Namens „Kusber“, vielleicht vorher nicht gespeichert, vielleicht Duplikate noch in der Anzeige

login : henning
editor version : 4.12.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / phycobank
schema version : 4.7.0.0.201710040000
os : Windows 7 6.1 amd64
java : 1.8.0_151
eu.etaxonomy.cdm.strategy.merge.MergeException: The merge candidate is not available anymore.
               at eu.etaxonomy.cdm.api.service.CommonServiceImpl.merge(CommonServiceImpl.java:279)
               at sun.reflect.GeneratedMethodAccessor9735.invoke(Unknown Source)
               at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
               at java.lang.reflect.Method.invoke(Method.java:498)
               at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:302)
               at

this can be fixed by reload the objects after deduplication


Related issues

Is duplicate of EDIT - bug #7129: after deduplication bulkeditor should load the entitiesDuplicateKatja Luther

Actions
Actions #1

Updated by Katja Luther over 4 years ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

please review

Actions #2

Updated by Katja Luther over 4 years ago

  • % Done changed from 0 to 50
Actions #3

Updated by Katja Luther over 4 years ago

  • Is duplicate of bug #7129: after deduplication bulkeditor should load the entities added
Actions #4

Updated by Katja Luther over 4 years ago

  • Status changed from Resolved to Duplicate
Actions #5

Updated by Andreas Müller over 4 years ago

  • Target version deleted (Release 4.13)
Actions

Also available in: Atom PDF