Project

General

Profile

feature request #7102

Enable EDIT and DELETE for specimen determinations

Added by Patrick Plitzner about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
12/01/2017
Due date:
% Done:

100%

Severity:
normal

picture936-1.png View (14.9 KB) Andreas Müller, 01/30/2018 11:59 AM

picture126-1.png View (29.7 KB) Andreas Müller, 05/15/2018 11:30 AM


Related issues

Copied to Edit - bug #7418: remaining specimen determination details view issues Closed 05/15/2018

Associated revisions

Revision 05945338 (diff)
Added by Patrick Plitzner about 1 year ago

fix #7102 Enable EDIT and DELETE for specimen determinations

Revision 4654a246 (diff)
Added by Patrick Plitzner 9 months ago

ref #7102 Fix delete behavior for taxon and taxon name

Revision 3dc6890f (diff)
Added by Patrick Plitzner 9 months ago

ref #7102 Enable wizard for taxa editing

Revision 6fca42dd (diff)
Added by Patrick Plitzner 7 months ago

ref #7102 Avoid deleting taxon name when deleting taxon

History

#1 Updated by Patrick Plitzner about 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Patrick Plitzner about 1 year ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

#3 Updated by Andreas Müller 10 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Delete on taxon gave an NPE

login : admin
editor version : 4.13.0.201801292346
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.ui.section.occurrence.DeterminationEventDetailElement.handleEvent(DeterminationEventDetailElement.java:122)
    at eu.etaxonomy.taxeditor.ui.section.AbstractEntityCollectionElement.propertyChange(AbstractEntityCollectionElement.java:160)
    at eu.etaxonomy.taxeditor.ui.element.AbstractCdmFormElement.firePropertyChangeEvent(AbstractCdmFormElement.java:234)
    at eu.etaxonomy.taxeditor.ui.selection.EntitySelectionElement$DeleteListener.widgetSelected(EntitySelectionElement.java:420)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

#4 Updated by Andreas Müller 10 months ago

EDIT for taxa gives a strange message (see screenshot)

#5 Updated by Andreas Müller 10 months ago

Deleting the name should also delete the taxon

#6 Updated by Andreas Müller 10 months ago

Andreas Müller wrote:

Deleting the name should also delete the taxon

This sometimes works immediately but after saving, clicking on another record and going back to the record the taxon is there again.
After full reload even the name is there again because it is reloaded by the CdmPreDataChangeListener.

#7 Updated by Patrick Plitzner 10 months ago

  • Target version changed from Release 4.12 to Release 5.0

move this forgotten issue to current milestone

#8 Updated by Patrick Plitzner 9 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 70

#9 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Andreas Müller wrote:

Andreas Müller wrote:

Deleting the name should also delete the taxon

This sometimes works immediately but after saving, clicking on another record and going back to the record the taxon is there again.
After full reload even the name is there again because it is reloaded by the CdmPreDataChangeListener.

This problem still exists.

Also when deleting the taxon the name is also deleted. This is not wanted. Only when deleting the name the taxon should be automatically deleted.

Note: saving here usually does not lead to a disabled save symbol after save. Maybe this can be fixed also
Note2: if there is a longer result list(tree) saving leads to a scroll down which unexpected

#10 Updated by Patrick Plitzner 7 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 70 to 80

Can you please check again if the issues last mentioned still exist. I fixed the unintended deletion of the taxon name but I could not reproduce the other issues.
And what view is scrolled when saving?

#11 Updated by Andreas Müller 7 months ago

Patrick Plitzner wrote:

And what view is scrolled when saving?

The specimen tree editor view, see attachement.

#12 Updated by Andreas Müller 7 months ago

Patrick Plitzner wrote:

Can you please check again if the issues last mentioned still exist. I fixed the unintended deletion of the taxon name but I could not reproduce the other issues.

I also could not reproduce anymore.

#13 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

One more related issue: when adding a taxon or name, the according text fields do not change their size but stay in single line mode. Usually for taxon representation but also for names we need 2 or more lines. It only changes size if resizing e.g. the width of the details view or by resellecting the specimen.

So this and the scrolling issue are remaining from this ticket. Feel free to open new ticket(s) if necessary.

#14 Updated by Patrick Plitzner 7 months ago

  • Related to bug #7418: remaining specimen determination details view issues added

#15 Updated by Patrick Plitzner 7 months ago

  • Related to deleted (bug #7418: remaining specimen determination details view issues)

#16 Updated by Patrick Plitzner 7 months ago

  • Copied to bug #7418: remaining specimen determination details view issues added

#17 Updated by Patrick Plitzner 7 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)