Project

General

Profile

bug #7079

P2 updates not found

Added by Patrick Plitzner about 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
11/22/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

The behavior of the automatic update is somewhat undeterministic: On some systems it works and on some it doesn't. There are even cases where only the nightly update or only the stable update works.

We have to investigate how to deterministically reproduce the problem.

P2 caches update information. This could also be a problem.

p2 cache

The p2 cache is located in the Taxeditor installation folder at ./p2/org.eclipse.equinox.p2.repository/cache this folder contains a file with a cryptic name. In my case it is named -622154754. This file is an xz archive, which seems to have the same content as the content.xml.xzin the p2 download site. Maybe this is exactly the file which has been downloaded from the update site.


repeating description of #5061 which has been set as duplicate of this issue:

This may be due to http://eclipsesource.com/blogs/2012/08/31/reloading-your-p2-cache/

We can solve this problem by simply forcing a reload of the p2 caches always before the update check, but first we need to confirm that this is indeed the problem.

This can be checked by choosing Preferences -> Install / Update -> Available Software Sites. Then select the nightly site and click reload. If this works then it should be the cache that is causing the problem.


wireshark-screenshot.png View (266 KB) Andreas Kohlbecker, 11/22/2017 12:38 PM

wireshark-log-2018-02-15-1.png View (51.7 KB) Andreas Kohlbecker, 02/15/2018 05:41 PM

content-2018-02-15_16-26.xml.xz (47.3 KB) Andreas Kohlbecker, 02/15/2018 05:44 PM

wireshark-log-after-reload.png View (125 KB) Andreas Kohlbecker, 02/15/2018 05:49 PM


Related issues

Related to Edit - feature request #4452: p2 update problem with nebula compositetable dependency Closed 10/28/2014
Related to Edit - bug #5430: P2 update of Taxonomic Editor bundled with JRE does not work New 07/06/2016
Related to Edit - feature request #7076: Add Nebula CompositeTable as direct dependency Closed 11/15/2017
Related to Edit - bug #7279: p2 sites are extremely huge Closed 02/20/2018

Associated revisions

Revision b1d99f9a (diff)
Added by Patrick Plitzner 10 months ago

ref #7079 Remove filter for update site

  • this may resolve some of the problems with the p2 updates because now all dependencies will be uploaded to the update site

Revision 5987bc1c (diff)
Added by Patrick Plitzner 10 months ago

ref #7079, #7076 Add nebula composite table as update site dependency

  • after removing the filter for the update site (#7079) the nebula composite table can be added as an update site dependency

Revision 87f1ced1 (diff)
Added by Patrick Plitzner 10 months ago

ref #7079, #7076 Add composite tabel dependency to product launch

History

#1 Updated by Andreas Kohlbecker about 1 year ago

Hallo,

ich habe mir das geupdate des Editors in der develop version mal im wireshark angesehen:

Es sieht so aus als würde der taxeditor nach dem 2ten redirect einfach nicht weiter machen .

Andreas

#2 Updated by Andreas Müller about 1 year ago

#3 Updated by Andreas Müller about 1 year ago

  • Related to bug #5430: P2 update of Taxonomic Editor bundled with JRE does not work added

#5 Updated by Andreas Müller about 1 year ago

Patrick, could you please check if #5061 and this ticket are duplicates?

#8 Updated by Patrick Plitzner 10 months ago

#9 Updated by Andreas Kohlbecker 10 months ago

Es sieht so aus als würde der taxeditor nach dem 2ten redirect einfach nicht weiter machen .

Sorry, das war quatsch, der redirect geht auf einen URL mit dem HTTPS Protokol, das bedeutet. Ab diesem Punkt ist die Kommunikation per SSL oder TSL verschlüsslt, daher erfasst der HTTP filter in wireshark den Traffic nicht mehr. Um auch den verschlüsselten Traffic analysieren zu können, muss er in wireshark entschlüsslelt werden. Wie das geht steht hier beschrieben: https://blog.stalkr.net/2010/03/codegate-decrypting-https-ssl-rsa-768.html

#10 Updated by Andreas Kohlbecker 10 months ago

Ich habe testweise den redirect auf https im server deaktiviert und das update hat prompt geklappt.

@patrick: Steht in der eclipse Dokumentation zu den update sites etwas https, ssl oder tsl? Gibt es in diesem Zusammenhang bekannte Probleme?

Ich habe versucht die update site aus dem redirect explizit aus zu schließen, hatte aber bislang keinen Erfolg damit.

#11 Updated by Patrick Plitzner 10 months ago

Ah, das ist ja interessant. Weiß nicht, ob dort etwas steht, aber ich werde mal schauen.

#12 Updated by Andreas Kohlbecker 10 months ago

ich habe den redirect auf https wieder deaktiviert, so dass die updates für nightly wieder funktionieren müssen.

Es werden aber keine Upadates gefunden.

wie in wireshark zu sehen ist holt sich der editor die content.xml.xz und bricht dann ab:

ein cache problem? oder unterscheiden sich die content.xml.xz der nightly build einfach nicht?

dies ist die aktuelle content.xml.xz: content-2018-02-15_16-26.xml.xz

#14 Updated by Andreas Kohlbecker 10 months ago

nach dem "reload" wie in #5061 empfohlen wird wesentlich mehr von der Update site herunter geladen:

Aber noch immer "No updates found!"

Auch nach einen Neutstart des Editors keine Veränderung.

#15 Updated by Andreas Kohlbecker 10 months ago

  • Description updated (diff)

#16 Updated by Andreas Kohlbecker 10 months ago

ich habe den redirect auf https wieder aktiviert

#17 Updated by Andreas Kohlbecker 10 months ago

  • Description updated (diff)

supplying some more details to the issue description ...

#18 Updated by Andreas Kohlbecker 10 months ago

test:

1 . deleted exiting ./p2/org.eclipse.equinox.p2.repository/cache/-622154754 file which had the md5 sum: 0c798397f7bd1a77065d591075b195fa
2. trying update ... no updates found
3. the ./p2/org.eclipse.equinox.p2.repository/cache/-622154754 has been restored and has been obviously been updated, it has a new md5 sum: 20d10682041b1bde580ba4700e139cce which exactly matches the content.xml.xz file in the update site. This finding supports the observations made with wireshark.

#19 Updated by Andreas Kohlbecker 10 months ago

  • Related to bug #7279: p2 sites are extremely huge added

#20 Updated by Andreas Kohlbecker 10 months ago

something extremely interesting happened:

After deleting and recreating the taxeditor/update/nightly folder the update suddenly worked, see #7279.
Maybe the update sizes contain old files which confuse the p2 update manager?

#21 Updated by Patrick Plitzner 10 months ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Kohlbecker
  • Target version changed from Unassigned CDM tickets to Release 5.0
  • % Done changed from 0 to 50

By clearing the update site with every build (#7279) This issue seems to be solved.

#22 Updated by Andreas Kohlbecker 9 months ago

we need to review and test this once again after the release 4.15 to sure it is fixed.

#23 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Kohlbecker to Patrick Plitzner

It looks like nightly update does not work anymore in 5.1-Snapshot

#24 Updated by Patrick Plitzner 6 months ago

  • Assignee changed from Patrick Plitzner to Andreas Kohlbecker

The update did not work for after the release because of a wrong version tag due to the manual update script.

This has already been fixed with taxeditor|9fb97d484e04342323e25b786819acebc94289de and has already been tested.

@Andreas K.: Can you test this again. But you need to have a downloaded nightly build after this commit.

#25 Updated by Andreas Kohlbecker 6 months ago

  • Assignee changed from Andreas Kohlbecker to Patrick Plitzner

Patrick Plitzner wrote:

@Andreas K.: Can you test this again. But you need to have a downloaded nightly build after this commit.

Updating the version 5.1.0.201806110837 to the latest nightly build 5.1.0.201806251348 worked for me

#26 Updated by Patrick Plitzner 6 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)