Project

General

Profile

bug #7077

INameService.deleteTypeDesignation(TaxonName name, TypeDesignationBase typeDesignation) should delete the type designation also from Registrations

Added by Andreas Kohlbecker about 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
New
Category:
cdmlib
Target version:
Start date:
11/16/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

Registrations have relation to TypeDesignationBase, deleted TypeDesignations should also be removed from there.


Related issues

Precedes Edit - task #7636: remove obsolete code which dissociates removed TypeDesignations from Registrations Closed 11/17/2017

Associated revisions

Revision 9b23bbdc (diff)
Added by Katja Luther about 1 year ago

fix #7077: when delete a typeDesignation, remove it from registration

Revision 6c782c0a (diff)
Added by Andreas Kohlbecker 10 months ago

ref #7077 removing 'hack' from test after the issue has been fixed

History

#1 Updated by Andreas Müller about 1 year ago

  • Subject changed from INameService.deleteTypeDesignation(TaxonName name, TypeDesignationBase typeDesignation) should the typeDesignation also from Registrations to INameService.deleteTypeDesignation(TaxonName name, TypeDesignationBase typeDesignation) should delete the type designation also from Registrations

Can you give a bit more inside what exactly the problem is?

#2 Updated by Andreas Müller about 1 year ago

  • Assignee changed from Andreas Müller to Katja Luther
  • Target version changed from Unassigned CDM tickets to Release 4.12

Andreas Müller wrote:

Can you give a bit more inside what exactly the problem is?

Ahh, sorry. You are referring to a service layer call. Than it is probably clear. I pass this to KL.

#3 Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 4.12 to Release 4.13

#4 Updated by Katja Luther about 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#5 Updated by Katja Luther about 1 year ago

  • Assignee changed from Katja Luther to Andreas Kohlbecker

please review and check whether everything works as expected

#6 Updated by Andreas Kohlbecker about 1 year ago

sorry I cant check unless the test setup in cdm-vaadin is working

#7 Updated by Andreas Kohlbecker 10 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

The tests now runs successful even without the 'hack'

#8 Updated by Andreas Kohlbecker 4 months ago

  • Precedes task #7636: remove obsolete code which dissociates removed TypeDesignations from Registrations added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)