Project

General

Profile

feature request #7011

feature request #6565: [MASTER] Eclipse 4 Migration

Migrate group authority editor

Added by Patrick Plitzner about 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
10/09/2017
Due date:
% Done:

100%

Severity:
normal
Tags:

Associated revisions

Revision d0eb8b9f (diff)
Added by Patrick Plitzner about 1 year ago

fix #7011 Migrate group authority editor

Revision 0634d71b (diff)
Added by Patrick Plitzner about 1 year ago

ref #7011 Migrate dnd

Revision 907fd6eb (diff)
Added by Katja Luther 12 months ago

fix #7011: open the cdm authorities editor in editor area and fix that it is grayed

Revision 26bdf4ea (diff)
Added by Katja Luther 12 months ago

fix #7011: fragment.xmi missed to check in

Revision 4d7cb09d (diff)
Added by Patrick Plitzner 10 months ago

ref #7011 harmonize creation and showing of MParts

  • also allow authority editor to be opened in multiple parts

History

#1 Updated by Patrick Plitzner about 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Patrick Plitzner about 1 year ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

#3 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • Priority changed from New to Highest

D&D does not yet work. E.g. from Tax Navigator.

#4 Updated by Katja Luther about 1 year ago

D&D also does not work for nodes in taxonnavigator, maybe this has to be migrated first.

#5 Updated by Andreas Müller about 1 year ago

Katja Luther wrote:

D&D also does not work for nodes in taxonnavigator, maybe this has to be migrated first.

Seems to be fixed in navigator, but still does not work in authority editor.

#6 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 70

#7 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

D&D still does not work.

Also the editor should open in the Editor part (together with name editor, bulk editor, etc.), this is how it was in e3.

#8 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

D&D still does not work.

Sorry, I worked with an old version. D&D works now.

#9 Updated by Andreas Müller about 1 year ago

Saving does take extremely long or not work at all. Only save by close works fast.

#10 Updated by Andreas Müller about 1 year ago

Trying to open the editor again result in an CCE:

login : admin
editor version : 4.11.0.201711061648
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: java.lang.ClassCastException: eu.etaxonomy.taxeditor.editor.group.authority.e4.CdmAuthorityEditorE4 cannot be cast to eu.etaxonomy.taxeditor.bulkeditor.e4.BulkEditorE4
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerShowProcessor.processDynamicElements(MenuManagerShowProcessor.java:158)
    at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerShowProcessor.menuAboutToHide(MenuManagerShowProcessor.java:113)
    at org.eclipse.jface.internal.MenuManagerEventHelper.showEventPostHelper(MenuManagerEventHelper.java:92)
    at org.eclipse.jface.action.MenuManager.handleAboutToShow(MenuManager.java:471)
    at org.eclipse.jface.action.MenuManager.access$1(MenuManager.java:465)
    at org.eclipse.jface.action.MenuManager$2.menuShown(MenuManager.java:497)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:256)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1103)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1084)
    at org.eclipse.swt.widgets.Control.WM_INITMENUPOPUP(Control.java:5160)
    at org.eclipse.swt.widgets.Control.windowProc(Control.java:4828)
    at org.eclipse.swt.widgets.Canvas.windowProc(Canvas.java:359)
    at org.eclipse.swt.widgets.Decorations.windowProc(Decorations.java:1656)
    at org.eclipse.swt.widgets.Shell.windowProc(Shell.java:2199)
    at org.eclipse.swt.widgets.Display.windowProc(Display.java:5110)
    at org.eclipse.swt.internal.win32.OS.TrackPopupMenu(Native Method)
    at org.eclipse.swt.widgets.Menu._setVisible(Menu.java:262)
    at org.eclipse.swt.widgets.Display.runPopups(Display.java:4277)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3818)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.ClassCastException: eu.etaxonomy.taxeditor.editor.group.authority.e4.CdmAuthorityEditorE4 cannot be cast to eu.etaxonomy.taxeditor.bulkeditor.e4.BulkEditorE4
    at eu.etaxonomy.taxeditor.bulkeditor.e4.command.DynamicNewObjectMenuE4.aboutToShow(DynamicNewObjectMenuE4.java:50)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 46 more

#11 Updated by Andreas Müller about 1 year ago

Reopening the editor after having it moved results in a grey (empty) editor. After moving it to another part it shows the content.

What I did:

  • Open usergroup bulk
  • open rights editor (shows data)
  • move rights editor to "editor" part
  • close rights editor
  • reopen rights editor => grey + empty
  • move to other part => content shows up

#12 Updated by Katja Luther 12 months ago

Andreas Müller wrote:

Reopening the editor after having it moved results in a grey (empty) editor. After moving it to another part it shows the content.

What I did:

  • Open usergroup bulk
  • open rights editor (shows data)
  • move rights editor to "editor" part
  • close rights editor
  • reopen rights editor => grey + empty
  • move to other part => content shows up

opening another rights editor works again and opening the previously not correctly opened editor again works as well.

#13 Updated by Katja Luther 12 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 70 to 50

#14 Updated by Katja Luther 12 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 70

#15 Updated by Katja Luther 12 months ago

  • % Done changed from 70 to 50

#16 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner

this seems to fully work now

#17 Updated by Andreas Müller 8 months ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)