Project

General

Profile

bug #6924

Taxon name incorrect after swap synonym with accepted taxon

Added by Patrick Plitzner over 1 year ago. Updated about 1 year ago.

Status:
Worksforme
Priority:
New
Category:
taxeditor
Target version:
Start date:
08/29/2017
Due date:
% Done:

0%

Severity:
normal
Found in Version:

Description

After I swapped the synonym with the accepted taxon it seems like only the name has changed but not the taxon.
Before the taxon was Abiess and the synonym was Abiecs
(see attached screenshot)

Please change Category if this is actually a cdmlib issue.

swapAccepted.png View (61.6 KB) Patrick Plitzner, 08/29/2017 05:15 PM

picture818-1.png View (73 KB) Patrick Plitzner, 11/02/2017 03:40 PM

picture471-1.png View (24.5 KB) Katja Luther, 11/02/2017 05:10 PM


Related issues

Copied to Edit - bug #7067: Improve swap accepted with synonym configurable New 11/07/2017

Associated revisions

Revision 180b1d40 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6924 Invoke operation onComplete() method in runnable

History

#1 Updated by Andreas Müller about 1 year ago

  • Target version changed from Unassigned CDM tickets to Release 4.11

is this still an open issue?

#2 Updated by Katja Luther about 1 year ago

  • Status changed from New to Worksforme
  • Target version deleted (Release 4.11)

No, I think this was a refresh problem of the details view

#3 Updated by Andreas Müller about 1 year ago

  • Status changed from Worksforme to Resolved

Patrick, can you finally review this as you created the ticket?

#4 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Resolved to Feedback
  • Target version set to Release 4.11

This is still the same for me. The taxon and synonym swap in the editor but in the details view and in the title of the name editor it still shows the old name. Even after reconnect.

#5 Updated by Katja Luther about 1 year ago

really strange for me it works, but the last time I did it, an nearly empty message dialog pops up

no log message but in eclipse: WARN [eu.etaxonomy.taxeditor.editor.name.e4.handler.SwapSynonymAndAcceptedHandlerE4$1] -

but reopening shows the correct result

#6 Updated by Katja Luther about 1 year ago

  • Assignee changed from Katja Luther to Patrick Plitzner

#7 Updated by Patrick Plitzner about 1 year ago

The strange message should be fixed now. But still the problem is the same. I attached another screenshot. Syn is selected which is now the accepted taxon after swapping but in the details view you see that the taxon is still Acc. Only the name is Syn.

#8 Updated by Katja Luther about 1 year ago

very strange... I tested again with the actual nightly build and it works for me, in the screenshot syn was the synonym and is now the accepted taxon

#9 Updated by Patrick Plitzner about 1 year ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

@AM: Could you test this on your machine and see if you can reproduce that behavior?

#10 Updated by Andreas Müller about 1 year ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

I can't reproduce the problem. The only refresh problem I see is that the navigator is not refreshed and still shows the old accepted taxon instead of the new one. Should we create a new ticket for this?

But it is true that only the name is changed. The Taxon and Synonym objects are kept. This you can see by comparing IDs in supplemental data. Also the sec reference is not changed and stays with the according TaxonBase. Usually this is not an issue as most Synonyms have the same sec as the accepted taxon, but there are exceptions. Maybe we should show a dialog asking if the sec references should be kept or also switched for cases where the sec references are not equal. Also keeping the id might be not wanted in some cases. But these are all different issues.

Patrick did you test with nightly or from IDE? Did you also test with Windows?

#11 Updated by Patrick Plitzner about 1 year ago

I only tested from IDE and on linux

#12 Updated by Andreas Müller about 1 year ago

Patrick Plitzner wrote:

I only tested from IDE and on linux

Could you test with nightly, and if still there with Windows?

#13 Updated by Patrick Plitzner about 1 year ago

With the current nightly it worked. The details view show the correct name.

#14 Updated by Andreas Müller about 1 year ago

  • Status changed from Feedback to Worksforme

OK, so I close the ticket as works for me?

#15 Updated by Andreas Müller about 1 year ago

  • Copied to bug #7067: Improve swap accepted with synonym configurable added

#16 Updated by Patrick Plitzner about 1 year ago

ok

#17 Updated by Andreas Müller about 1 year ago

moved new issues from #note-10 to new ticket #7067

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)