Project

General

Profile

feature request #6908

feature request #6565: [MASTER] Eclipse 4 Migration

Migrate polytomous key module

Added by Patrick Plitzner over 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
08/14/2017
Due date:
% Done:

100%

Severity:
normal
Tags:

Related issues

Copied to Edit - bug #7038: PK Graph view issues New 10/26/2017

Associated revisions

Revision 3b4a059e (diff)
Added by Patrick Plitzner over 1 year ago

ref #6908 #6907 refactor abstract viewer class

Revision bc91d03c (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Migrate polytomous key list editor

  • migrate some other parts and handlers

Revision 360b73f0 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Migrate polytomous key list editor handlers

Revision 3f09ac44 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Migrate polytomous key list and graph editor

Revision 91333bc6 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Migrate remaining polytomous context menus and handlers

Revision 05429a19 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Fix dirty flag handling in key list editor

Revision 371cab7b (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Add polytomous key editor to "Show view" menu

Revision 225ce420 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Enable details view for polytomous graph

Revision d0adff9a (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Disable "Open in bulk editor" for PK

Revision a1880adb (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Close PK editor when deleting key

Revision 5fad9b4a (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Fix activation of handlers for PK list editor

Revision c4667dc4 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Allow opening multiple PK editors

Revision edd262f4 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Allow opening multiple PK (+graph) editors

Revision b9742a2a (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Avoid opening the same PK in multiple editors

Revision 6ec96dc0 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6908 Enable supplemental view for PK list editor

Revision d11a617c (diff)
Added by Katja Luther about 1 year ago

fix #6908: version conflict of JPA was the reason of the nosuchmethod exception

Revision 6c8dc8d3 (diff)
Added by Katja Luther about 1 year ago

ref #6908: set dirty flag in polytomous key node editor for all operations

History

#1 Updated by Patrick Plitzner about 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • Target version changed from Unassigned CDM tickets to Release 4.11
  • % Done changed from 0 to 50

#2 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

The view is still missing in the show view menu (should be in topmost group together with taxon navigator which is on bottom in the current nightly)

#3 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

The view is still missing in the show view menu (should be in topmost group together with taxon navigator which is on bottom in the current nightly)

I can't review as long as the menu is missing.

#4 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

added the menu entry

#5 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

In the PK View there is a context menu entry "Open in"-> Bulk Editor (disabled) now. This hasn't been there before and also does not make any sense in this context. Polytomous Keys can't be opened in bulk editor.

#6 Updated by Andreas Müller about 1 year ago

When deleting a key the according editor is not closed. In e3 it was closed (and should be closed).

#7 Updated by Andreas Müller about 1 year ago

When creating a new key and then trying to create a new alternative via context menu (should this menu entry be available at all in a completely empty key?) I got multiple exceptions. First:

login : admin
editor version : 4.11.0.201710181800
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.editor.key.polytomous.e4.handler.CreateSiblingNodeHandlerE4.execute(CreateSiblingNodeHandlerE4.java:41)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 36 more

after closing and reopening the key editor I got

login : admin
editor version : 4.11.0.201710181800
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: java.lang.ClassCastException: eu.etaxonomy.cdm.model.description.PolytomousKey cannot be cast to eu.etaxonomy.cdm.model.description.PolytomousKeyNode
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.ClassCastException: eu.etaxonomy.cdm.model.description.PolytomousKey cannot be cast to eu.etaxonomy.cdm.model.description.PolytomousKeyNode
    at eu.etaxonomy.taxeditor.editor.key.polytomous.e4.handler.CreateSiblingNodeHandlerE4.execute(CreateSiblingNodeHandlerE4.java:39)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 36 more

#8 Updated by Andreas Müller about 1 year ago

The label for the graph editor is to general "Polytomous Key Graph Editor". It should include the name of the key. "Polytomous Key" and "Editor" can be removed I think.

#9 Updated by Andreas Müller about 1 year ago

For the graph editor the details view does not show the details data of the selected node.

#10 Updated by Andreas Müller about 1 year ago

For the graph editor I would expect a context menu for "add new child", etc. But I can see, that this is already missing in the e3 version. So it is not a migration issue. But we may want to open a new ticket for it.

#11 Updated by Andreas Müller about 1 year ago

The zooming mechanism is not available anymore. This is good as the zoom does not clutter the symbol bar anymore with multiple dropdown menus. However a zoom functionality is helpful for large keys (but priority is not so high if this is difficult to implement)

#12 Updated by Andreas Müller about 1 year ago

It is not possible to open multiple keys anymore. The existing open view is replaced instead with the new data (did not check if data changes are saved correctly).

#13 Updated by Andreas Müller about 1 year ago

When entering data into statement I got

login : admin
editor version : 4.11.0.201710181800
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.core.runtime.AssertionFailedException: null argument:
    at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:85)
    at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:73)
    at org.eclipse.jface.viewers.StructuredViewer.update(StructuredViewer.java:2089)
    at org.eclipse.jface.viewers.ColumnViewer.update(ColumnViewer.java:542)
    at eu.etaxonomy.taxeditor.editor.key.polytomous.e4.PolytomousKeyListEditorE4.changed(PolytomousKeyListEditorE4.java:280)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4.changed(AbstractCdmEditorPartE4.java:148)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.markViewPartDirty(AbstractCdmDataViewerE4.java:103)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsViewerE4.markViewPartDirty(DetailsViewerE4.java:187)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4$1.dirtyStateChanged(AbstractCdmDataViewerE4.java:73)
    at org.eclipse.ui.forms.AbstractFormPart.markDirty(AbstractFormPart.java:93)
    at eu.etaxonomy.taxeditor.view.detail.CdmSectionPart.propertyChange(CdmSectionPart.java:192)
    at eu.etaxonomy.taxeditor.ui.element.AbstractCdmFormElement.firePropertyChangeEvent(AbstractCdmFormElement.java:234)
    at eu.etaxonomy.taxeditor.ui.element.MultilanguageTextElement.propertyChange(MultilanguageTextElement.java:262)
    at eu.etaxonomy.taxeditor.ui.element.KeyStatementElement.propertyChange(KeyStatementElement.java:98)
    at eu.etaxonomy.taxeditor.ui.element.AbstractCdmFormElement.firePropertyChangeEvent(AbstractCdmFormElement.java:234)
    at eu.etaxonomy.taxeditor.ui.element.TextWithLabelElement.modifyText(TextWithLabelElement.java:188)
    at eu.etaxonomy.taxeditor.ui.element.LanguageStringWithLabelElement.modifyText(LanguageStringWithLabelElement.java:93)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:180)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1103)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1084)
    at org.eclipse.swt.widgets.Text.wmCommandChild(Text.java:3122)
    at org.eclipse.swt.widgets.Control.WM_COMMAND(Control.java:4947)
    at org.eclipse.swt.widgets.Control.windowProc(Control.java:4802)
    at org.eclipse.swt.widgets.Display.windowProc(Display.java:5123)
    at org.eclipse.swt.internal.win32.OS.CallWindowProcW(Native Method)
    at org.eclipse.swt.internal.win32.OS.CallWindowProc(OS.java:2446)
    at org.eclipse.swt.widgets.Text.callWindowProc(Text.java:262)
    at org.eclipse.swt.widgets.Control.windowProc(Control.java:4897)
    at org.eclipse.swt.widgets.Text.windowProc(Text.java:2704)
    at org.eclipse.swt.widgets.Display.windowProc(Display.java:5110)
    at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
    at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2552)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3822)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

#14 Updated by Andreas Müller about 1 year ago

same when entering data into any other field in details view

#15 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

It is not possible to open multiple keys anymore. The existing open view is replaced instead with the new data (did not check if data changes are saved correctly).

The same happens with the graph editor.

By the way, we could use the "Open in" menu entry to distinguish if the key should be opened in graph or table/list editor.

Only general problem I see is the synchronization between the 2 representations. In e3 at least the details view is synchronized as both are handled in the same editor as "sub-tabs". Can't test if this also works in e4 as graph editor is not yet related to details view (see above).

#16 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 70

Fixed comment #6908#note-5, #6908#note-6, #6908#note-9, #6908#note-7, #6908#note-12 and #6908#note-14

Created ticket for missing graph view issues -> #7038

Cannot reproduce the exceptions happening when editing in details view. This could be because of a corrupted state due to previous exceptions you had.

#17 Updated by Patrick Plitzner about 1 year ago

  • Copied to bug #7038: PK Graph view issues added

#18 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

The same problem as in bulk editor. If no name editor is open than the details view gets empty as soon as you try to click on it somewhere. (#7000)

#19 Updated by Andreas Müller about 1 year ago

When trying to add the first node to a PK via xxx I got a NoSuchMethod exception. This is critical as it prevents from creating any new key with content.

login : admin
editor version : 4.11.0.201711061648
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NoSuchMethodError: org.hibernate.collection.internal.PersistentList.isInitialized()Z)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NoSuchMethodError: org.hibernate.collection.internal.PersistentList.isInitialized()Z
    at org.hibernate.collection.internal.PersistentList.add(PersistentList.java:318)
    at eu.etaxonomy.cdm.model.description.PolytomousKeyNode.addChild(PolytomousKeyNode.java:477)
    at eu.etaxonomy.taxeditor.editor.key.polytomous.operation.InsertPolytomousKeyNodeOperation.doSimpleExecute(InsertPolytomousKeyNodeOperation.java:65)
    at eu.etaxonomy.taxeditor.operation.RemotingCdmDefaultOperation.doExecute(RemotingCdmDefaultOperation.java:37)
    at eu.etaxonomy.taxeditor.operation.RemotingCdmOperation.execute(RemotingCdmOperation.java:50)
    at eu.etaxonomy.taxeditor.model.AbstractUtility.lambda$4(AbstractUtility.java:196)
    at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
    at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 23 more

#20 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

The label for the graph editor is to general "Polytomous Key Graph Editor". It should include the name of the key. "Polytomous Key" and "Editor" can be removed I think.

It is much better now, but maybe we can do something like "Graph:{name}". Only the name might be confusing in some usecases. (uncritical issue)

#21 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

When trying to add the first node to a PK via xxx I got a NoSuchMethod exception. This is critical as it prevents from creating any new key with content.

The problem here was, that "new alternative" was not shown as a menu option. After a while, maybe after reopening the key it was shown, but then an NPE was thrown when using "new alternative":

login : admin
editor version : 4.11.0.201711061648
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.editor.key.polytomous.operation.CreateNodeOperation.execute(CreateNodeOperation.java:40)
    at eu.etaxonomy.taxeditor.model.AbstractUtility.lambda$3(AbstractUtility.java:140)
    at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
    at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 23 more

#22 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

Andreas Müller wrote:

When trying to add the first node to a PK via xxx I got a NoSuchMethod exception. This is critical as it prevents from creating any new key with content.

The problem here was, that "new alternative" was not shown as a menu option. After a while, maybe after reopening the key it was shown, but then an NPE was thrown when using "new alternative":

It looks like the first problem already existed in 4.10 so I am not sure if it is e4 related. However, it only appeared recently, and wasn't there before.

#23 Updated by Andreas Müller about 1 year ago

dirty flag is not set if choosing "new key number"-> "after current node" (and maybe after some others, e.g. "new alternative"), also not immediate save is performed.
It seems to be correctly for "new key number"-> "before current node".
.

#24 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

When entering data into statement I got

login : admin
editor version : 4.11.0.201710181800
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.core.runtime.AssertionFailedException: null argument:
  at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:85)
  at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:73)
  at org.eclipse.jface.viewers.StructuredViewer.update(StructuredViewer.java:2089)

This was observed again

#25 Updated by Andreas Müller about 1 year ago

The save behavior for PK and especially PK Graph is not very clear. Often it seems not to save if pressing save button. Also dirty flag is not reset. Please try to test on your own as it is hard to explain in detail.

#26 Updated by Katja Luther about 1 year ago

  • Status changed from Feedback to Resolved
  • % Done changed from 70 to 50

#27 Updated by Andreas Müller about 1 year ago

Open graph views are not synchronized anymore with the list view. E.g. if I add a new alternative in the list view it is not shown in the graph view, even after save (this is not release critical as the graph is not very often used)

#28 Updated by Andreas Müller about 1 year ago

When the focus is on PK node (e.g. click into statement textfield) the supplemental data field shows label "SpecimenTypeDesignation" (is this only a label issue or is it a critical issue where data is not correctly linked?)

#29 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

When the focus is on PK node (e.g. click into statement textfield) the supplemental data field shows label "SpecimenTypeDesignation" (is this only a label issue or is it a critical issue where data is not correctly linked?)

The same happens when clicking in the Polytomous Key part of the details view. Both can not be correct as the SupplData view shows only annotations and markers while PKs are identifiable and should have more data and PKnodes are only versionable and should have only id und uuid as supplemental data.

This is critical as Ralf needs the supplemental data for some new keys.

#30 Updated by Andreas Müller about 1 year ago

Except for the last 3 issues and for the labeling of the graph view #note-20 all other open issues seem to be fixed. Editing the key and saving works fine now.

#31 Updated by Andreas Müller about 1 year ago

Andreas Müller wrote:

When the focus is on PK node (e.g. click into statement textfield) the supplemental data field shows label "SpecimenTypeDesignation" (is this only a label issue or is it a critical issue where data is not correctly linked?)

Looks like this issue was due to an exceptional state of the current TaxEditor instance. Restarting the TaxEditor solved the issue.

#32 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Closed

Close this ticket and move uncritical open issues to #7038. All open issues are related to the graph view.

#33 Updated by Andreas Müller 7 months ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)