Project

General

Profile

feature request #6907

feature request #6565: [MASTER] Eclipse 4 Migration

Migrate factual data view

Added by Patrick Plitzner over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
08/14/2017
Due date:
% Done:

100%

Severity:
normal
Tags:

Related issues

Related to Edit - bug #6923: move description to other taxon command fails in factual data view Closed 08/28/2017

Associated revisions

Revision 860fc861 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907 Migrate factual data view

Revision 9ef7ae67 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907 Fix NPE in move factual data operations

Revision 2965ad0f (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907 Show factual data for derivatives

Revision 0619074d (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907 Filter menu item visibility

Revision b99a3ada (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907, #6906 Remove multi-select from media and factual data view

Revision 7cce7fa3 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907 Disable move description operations for specimen editor

Revision 3b4a059e (diff)
Added by Patrick Plitzner over 1 year ago

ref #6908 #6907 refactor abstract viewer class

Revision 43966327 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907 remove unused exception

Revision 7a023b3e (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907 migrate remaining handlers

Revision 9d89dd89 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6907 Fix selection handling on description elements

Revision 6393027d (diff)
Added by Patrick Plitzner about 1 year ago

ref #6907, #6597 Refresh details view after changing desc element

Revision bd118a57 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6907 Add toolbar to factual data view

  • add "show only inidividual association" item

Revision cc975ee6 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6907 Add "collapse" item to factual data part

Revision 8263cbc9 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6907, #6931 Add "expand" item to factual data part and uses part

History

#1 Updated by Patrick Plitzner over 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther
  • Target version changed from Unassigned CDM tickets to Release 4.10
  • % Done changed from 0 to 50

#2 Updated by Katja Luther over 1 year ago

looks fine, but the command "move description to other taxon" fails, the description parameter is null -> new ticket #6923

#3 Updated by Katja Luther over 1 year ago

  • Related to bug #6923: move description to other taxon command fails in factual data view added

#4 Updated by Katja Luther over 1 year ago

  • Assignee changed from Katja Luther to Patrick Plitzner

clicking on new-> Distribution throws an NPE because the selection is null.

#5 Updated by Patrick Plitzner over 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Patrick Plitzner to Katja Luther

Katja Luther wrote:

clicking on new-> Distribution throws an NPE because the selection is null.

I cannot reproduce that behavior

#6 Updated by Katja Luther over 1 year ago

If you already have a descriptionelement and wants to create a new one.

#7 Updated by Katja Luther over 1 year ago

  • Assignee changed from Katja Luther to Patrick Plitzner

#8 Updated by Patrick Plitzner over 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 50 to 80

#9 Updated by Katja Luther about 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Patrick Plitzner

seems to work now.

#10 Updated by Patrick Plitzner about 1 year ago

  • % Done changed from 80 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)