Project

General

Profile

bug #6843

AlgenRegistrierung - feature request #6169: Algae Registry web-application

resize problems of Popup editors when clicking contained elements

Added by Andreas Kohlbecker over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
New
Category:
cdm-vaadin
Target version:
Start date:
06/12/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

e.g. when clicking the lazy combobox in the Name editor it can happen that the popup window exceeds the body element without causing any scrollbar to be shown in the page so that it is possible to scroll down. the lower part of the window becomes unavailable

Associated revisions

Revision 7954536e (diff)
Added by Andreas Kohlbecker over 1 year ago

fix #6843 popup window content layouts are guaranteed to have full size

Revision 55f3f727 (diff)
Added by Andreas Kohlbecker over 1 year ago

fix #6843 avoiding oversized windows by setting a defined height

Revision 0af0ecf8 (diff)
Added by Andreas Kohlbecker over 1 year ago

fix #6843 improving AbstractPageView layout

History

#1 Updated by Andreas Kohlbecker over 1 year ago

This seems to be caused by the contained layouts having no size, see https://vaadin.com/forum/#!/thread/249127/249162

#2 Updated by Andreas Kohlbecker over 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 100 to 50

#3 Updated by Andreas Kohlbecker over 1 year ago

  • Status changed from Resolved to In Progress

unfortunately still not solved

#4 Updated by Andreas Kohlbecker over 1 year ago

  • Status changed from In Progress to Resolved

#5 Updated by Andreas Kohlbecker over 1 year ago

  • Status changed from Resolved to Closed

#6 Updated by Andreas Kohlbecker over 1 year ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)