Project

General

Profile

bug #6781

bug #6545: [MASTER] Eclipse 4 bugs

Automatic update does not work anymore for TaxEditor

Added by Andreas Müller over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
07/07/2017
Due date:
% Done:

100%

Severity:
critical
Found in Version:

Description

I tried to update from TaxEditor version 4.7 to version 4.8 but the update stopped in the middle without the following error message:

!ENTRY org.eclipse.equinox.p2.engine 4 4 2017-08-02 10:30:08.933
!MESSAGE An error occurred while collecting items to be installed
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2017-08-02 10:30:08.933
!MESSAGE session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
!SUBENTRY 1 org.eclipse.equinox.p2.transport.ecf 4 1200 2017-08-02 10:30:08.933
!MESSAGE Artifact not found: http://cybertaxonomy.eu/download/taxeditor/update/nightly/plugins/org.eclipse.nebula.widgets.compositetable_1.0.0.201706221838.jar.
!STACK 0
java.io.FileNotFoundException: http://cybertaxonomy.eu/download/taxeditor/update/nightly/plugins/org.eclipse.nebula.widgets.compositetable_1.0.0.201706221838.jar
    at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryStatusHelper.checkFileNotFound(RepositoryStatusHelper.java:297)
    at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.checkException(FileReader.java:480)
    at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.sendRetrieveRequest(FileReader.java:437)
    at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.readInto(FileReader.java:360)
    at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.download(RepositoryTransport.java:101)
    at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.download(RepositoryTransport.java:156)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:669)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:591)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:723)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.getArtifact(MirrorRequest.java:319)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transferSingle(MirrorRequest.java:288)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transfer(MirrorRequest.java:223)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.perform(MirrorRequest.java:153)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:707)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.DownloadJob.run(DownloadJob.java:63)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

It seems like there is something wrong with the dependency to the nebula widgets


Related issues

Related to Edit - feature request #4452: p2 update problem with nebula compositetable dependency Closed 10/28/2014

Associated revisions

Revision 6d3302a5 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6781 Replace nebula update site with 2016 archived one

Revision b632fb88 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6781 Replace nebula update site with 2016 archived one

History

#1 Updated by Andreas Müller over 1 year ago

  • Parent task set to #6565

#2 Updated by Andreas Müller over 1 year ago

  • Parent task changed from #6565 to #6545

#3 Updated by Patrick Plitzner over 1 year ago

  • Description updated (diff)

#4 Updated by Andreas Müller over 1 year ago

  • Target version changed from Unassigned CDM tickets to Release 4.10

#5 Updated by Patrick Plitzner over 1 year ago

#6 Updated by Patrick Plitzner over 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

I updated my week-old nightly (02.08) to the current version (08.08) and it worked. This did not succeed before the change of the update site for the nebula widget. So I guess this will now also work for the next release. But the next release still has to be downloaded once again to have the changes included. After that the update mechanism should work.

#7 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner

I updated from 4.9.1 to 4.9.2 without problems. So I guess the problem is solved.

Still not solved is the update for the jre version, at least on Windows, but this is another issue.

#8 Updated by Andreas Müller about 1 year ago

  • % Done changed from 0 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)