Project

General

Profile

bug #6769

Usages can not be created anymore in usage perspective

Added by Patrick Plitzner over 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
06/30/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

"ich habe jetzt auch die „Usage“ Perspektive getestet. Dort lassen sich derzeit auch keine Einzelnutzungen (DescriptionElements) anlegen.

Die Auswahl im entsprechenden right click Menu ändert nichts.

Beim Saven bekam ich dann zusätzlich redscreen stacktrace unten. Das liegt wohl daran, dass die für Usage benötigten Features nicht angelegt wurden. Ich glaube früher wurde das quasi beim erstmaligen öffnen der Perspektive für die gegebene Datenbank gemacht, bin mir aber nicht mehr ganz sicher. Hat London implementiert."


Related issues

Related to Edit - feature request #6931: Migrate uses view Closed 09/08/2017

History

#1 Updated by Andreas Müller over 1 year ago

  • Subject changed from red screen in taxon name editor when adding "Use summary" or "Use record" to Usages can not becreated anymore in Usage perspective
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • Target version changed from Unassigned CDM tickets to Release 4.8

The main problem here is, that facts (usages) can not be created. This reminds very much to similar problems in the facts view after refactoring e4.

Can you please check if it is related? If not we may decide who will be assignee and what priority.

#2 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 4.8 to Release 4.9

#3 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 4.9 to Release 4.10

#4 Updated by Andreas Müller about 1 year ago

  • Tags set to eclipse4
  • Subject changed from Usages can not becreated anymore in Usage perspective to Usages can not be created anymore in usage perspective
  • Description updated (diff)
  • Target version changed from Release 4.10 to Release 4.11

#5 Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 4.11 to Release 4.12

#6 Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 4.12 to Release 4.13

#7 Updated by Andreas Müller 10 months ago

  • Target version changed from Release 4.13 to Release 4.14

#8 Updated by Andreas Müller 10 months ago

  • Target version changed from Release 4.14 to Release 5.0

#9 Updated by Patrick Plitzner 9 months ago

  • Status changed from New to Feedback
  • Assignee changed from Patrick Plitzner to Andreas Müller

This works for me. Can you please check again?

#10 Updated by Andreas Müller 7 months ago

In a general DB I still could not create a new Usage record. Selecting "New Usage" had no effect. That might be related to the missing vocabularies in standard databases.

#11 Updated by Andreas Müller 7 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

The dirty flag does not work correctly yet.

Also as it is not disabled after first save I can save again. This save leads to the following reproducable exception, which is thrown during auditing and which is caused by a validation of GenusOrUninomial which is strange as it is not expected that any name is related. I tested with Calamus acanthochlamys J.Dransf. in palmae on test server.

login : admin
editor version : 4.14.1
server : test.e-taxonomy.eu (edit-test) / palmae
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: org.hibernate.AssertionFailure: Unable to perform beforeTransactionCompletion callback
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    ...
Caused by: org.hibernate.AssertionFailure: Unable to perform beforeTransactionCompletion callback
    at org.hibernate.engine.spi.ActionQueue$BeforeTransactionCompletionProcessQueue.beforeTransactionCompletion(ActionQueue.java:905)
    at org.hibernate.engine.spi.ActionQueue.beforeTransactionCompletion(ActionQueue.java:481)
    at org.hibernate.internal.SessionImpl.beforeTransactionCompletion(SessionImpl.java:2340)
    at org.hibernate.engine.jdbc.internal.JdbcCoordinatorImpl.beforeTransactionCompletion(JdbcCoordinatorImpl.java:485)
    at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl.beforeCompletionCallback(JdbcResourceLocalTransactionCoordinatorImpl.java:147)
    at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl.access$100(JdbcResourceLocalTransactionCoordinatorImpl.java:38)
    at org.hibernate.resource.transaction.backend.jdbc.internal.JdbcResourceLocalTransactionCoordinatorImpl$TransactionDriverControlImpl.commit(JdbcResourceLocalTransactionCoordinatorImpl.java:231)
    at org.hibernate.engine.transaction.internal.TransactionImpl.commit(TransactionImpl.java:65)
    at org.springframework.orm.hibernate5.HibernateTransactionManager.doCommit(HibernateTransactionManager.java:581)
    at org.springframework.transaction.support.AbstractPlatformTransactionManager.processCommit(AbstractPlatformTransactionManager.java:761)
    at org.springframework.transaction.support.AbstractPlatformTransactionManager.commit(AbstractPlatformTransactionManager.java:730)
    at org.springframework.transaction.interceptor.TransactionAspectSupport.commitTransactionAfterReturning(TransactionAspectSupport.java:485)
    at org.springframework.transaction.interceptor.TransactionAspectSupport.invokeWithinTransaction(TransactionAspectSupport.java:291)
    at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:96)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:208)
    at com.sun.proxy.$Proxy3079.merge(Unknown Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    ....java:55)
    ... 36 more
Caused by: javax.validation.ConstraintViolationException: Validation failed for classes [eu.etaxonomy.cdm.model.name.TaxonName] during update time for groups [javax.validation.groups.Default, ]
List of constraint violations:[
    ConstraintViolationImpl{interpolatedMessage='must be either null, or contain at least one non-whitespace character', propertyPath=genusOrUninomial, rootBeanClass=class eu.etaxonomy.cdm.model.name.TaxonName, messageTemplate='{eu.etaxonomy.cdm.validation.annotation.NullOrNotEmpty.message}'}
]
    at org.hibernate.cfg.beanvalidation.BeanValidationEventListener.validate(BeanValidationEventListener.java:138)
    at org.hibernate.cfg.beanvalidation.BeanValidationEventListener.onPreUpdate(BeanValidationEventListener.java:86)
    at org.hibernate.action.internal.EntityUpdateAction.preUpdate(EntityUpdateAction.java:244)
    at org.hibernate.action.internal.EntityUpdateAction.execute(EntityUpdateAction.java:118)
    at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:560)
    at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:434)
    at org.hibernate.event.internal.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:337)
    at org.hibernate.event.internal.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:39)
    at org.hibernate.internal.SessionImpl.flush(SessionImpl.java:1282)
    at org.hibernate.envers.internal.synchronization.AuditProcess.doBeforeTransactionCompletion(AuditProcess.java:156)
    at org.hibernate.envers.internal.synchronization.AuditProcessManager$1.doBeforeTransactionCompletion(AuditProcessManager.java:46)
    at org.hibernate.engine.spi.ActionQueue$BeforeTransactionCompletionProcessQueue.beforeTransactionCompletion(ActionQueue.java:899)
    ... 148 more

#12 Updated by Andreas Müller 7 months ago

#13 Updated by Andreas Müller 7 months ago

upps, I just see, I did the last testing with production (4.14.1), not nightly.
However, there is still a minor issue with the save button not being dirty as long as the focus is in details view. I will do a new review once this is fixed.

#14 Updated by Andreas Müller 7 months ago

Andreas Müller wrote:

In a general DB I still could not create a new Usage record. Selecting "New Usage" had no effect. That might be related to the missing vocabularies in standard databases.

This works now in nightly.

#15 Updated by Patrick Plitzner 7 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50

I fixed a ClassCastException in the SaveHandler. This should resolve the focus problem. taxeditor|da6720424e6100bc9e9abad24a8420a8a5d0a422

#16 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner

This seems to be fixed all.

#17 Updated by Andreas Müller 7 months ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)