Project

General

Profile

bug #6742

IAE when using "Link with taxon selection" in Specimen-Editor

Added by Andreas Müller over 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
06/20/2017
Due date:
% Done:

50%

Severity:
major
Found in Version:

Description

... with no taxon selected

login : admin
editor version : 4.8.0.201706201350
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.IllegalArgumentException: Object [Ljava.lang.Object;@38ae69f7 is neither a CdmBase nor a CDM "container")
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.IllegalArgumentException: Object [Ljava.lang.Object;@38ae69f7 is neither a CdmBase nor a CDM "container"
    at eu.etaxonomy.taxeditor.store.StoreUtil.getCdmEntity(StoreUtil.java:68)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.setEntity(AbstractCdmDetailElement.java:88)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailSection.setEntity(AbstractCdmDetailSection.java:125)
    at eu.etaxonomy.taxeditor.view.detail.CdmSectionPart.setFormInput(CdmSectionPart.java:147)
    at org.eclipse.ui.forms.ManagedForm.setInput(ManagedForm.java:210)
    at eu.etaxonomy.taxeditor.view.AbstractCdmDataViewer.refresh(AbstractCdmDataViewer.java:123)
    at eu.etaxonomy.taxeditor.view.AbstractCdmDataViewer.setInput(AbstractCdmDataViewer.java:109)
    at eu.etaxonomy.taxeditor.view.detail.DetailsViewer.setInput(DetailsViewer.java:161)
    at eu.etaxonomy.taxeditor.view.detail.DetailsViewPart.showViewer(DetailsViewPart.java:268)
    at eu.etaxonomy.taxeditor.view.detail.DetailsViewPart.selectionChanged_internal(DetailsViewPart.java:136)
    at eu.etaxonomy.taxeditor.view.AbstractCdmEditorViewPart$DelaySelection.run(AbstractCdmEditorViewPart.java:52)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 23 more

Associated revisions

Revision cb86d7ee (diff)
Added by Patrick Plitzner 3 months ago

fix #6742 Fix Link with taxon selection in specimen tree editor

History

#1 Updated by Patrick Plitzner 4 months ago

  • Status changed from New to Feedback
  • Assignee changed from Patrick Plitzner to Andreas Müller

@Andreas: I could not reproduce this behavior. Maybe this was fixed a while ago. Can you please test and close this ticket if it does not happen anymore?

#2 Updated by Andreas Müller 4 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.3

#3 Updated by Andreas Müller 3 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

I did not get the IAE anymore but also could not create any result. I tried to

  • Select or not select a taxon in taxon navigator
  • enable or disable the "link" button in taxon navigator
  • select or not select a taxon in the taxon filter of specimen tree editor
  • for all this tried to use the "link with taxon selection"

with no result. Either the list was shown as usual or the filter went away and the label said "no taxon selected" (though a taxon was selected). So how is this intended to be used?

#4 Updated by Patrick Plitzner 3 months ago

  • Target version changed from Release 5.3 to Release 5.4

#5 Updated by Patrick Plitzner 3 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 50

#6 Updated by Patrick Plitzner 3 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller
  • Target version changed from Release 5.4 to Release 5.3
  • % Done changed from 50 to 0

#7 Updated by Patrick Plitzner 3 months ago

  • % Done changed from 0 to 50

#8 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner

This works now.

We discussed to move the menu entry to an icon to make it more intuitive and present for the user.

Also discussed to allow null value for derivate type filter and multi select for taxon assignment.

Also label for taxon assignment could be changed to "assigned to taxon as "

All these issues will be new tickets.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)