Project

General

Profile

task #6736

Handle server not available user friendly

Added by Andreas Müller over 2 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
New
Assignee:
Category:
taxeditor
Target version:
-
Start date:
06/16/2017
Due date:
% Done:

0%

Severity:
normal

Description

During an export that was interrupted by a restarting CdmServer I got the below error.

The message is difficult to understand for ordinary users. We should make simple, e.g. "Server seems to be not available. Please retry later".

possibly duplicates (although different HTTP response code) #6355

Could not access HTTP invoker remote service at [...] nested exception is ... response code 502 .... with error trace below .....
login : 
editor version : 4.8.0.201706150749
server :  ()
schema version : 
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [http://test.e-taxonomy.eu:80/cdmserver/caryo_spp/remoting/io.service]; nested exception is org.apache.http.NoHttpResponseException: Did not receive successful HTTP response: status code = 502, status message = [Proxy Error]
    at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.convertHttpInvokerAccessException(HttpInvokerClientInterceptor.java:216)
    at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:147)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:208)
    at com.sun.proxy.$Proxy48.export(Unknown Source)
    at eu.etaxonomy.taxeditor.io.ExportManager$3.run(ExportManager.java:293)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: org.apache.http.NoHttpResponseException: Did not receive successful HTTP response: status code = 502, status message = [Proxy Error]
    at org.springframework.remoting.httpinvoker.HttpComponentsHttpInvokerRequestExecutor.validateResponse(HttpComponentsHttpInvokerRequestExecutor.java:357)
    at org.springframework.remoting.httpinvoker.HttpComponentsHttpInvokerRequestExecutor.doExecuteRequest(HttpComponentsHttpInvokerRequestExecutor.java:230)
    at eu.etaxonomy.taxeditor.service.CdmServiceRequestExecutor.doExecuteRequest(CdmServiceRequestExecutor.java:61)
    at org.springframework.remoting.httpinvoker.AbstractHttpInvokerRequestExecutor.executeRequest(AbstractHttpInvokerRequestExecutor.java:138)
    at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.executeRequest(HttpInvokerClientInterceptor.java:194)
    at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.executeRequest(HttpInvokerClientInterceptor.java:176)
    at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:144)
    ... 5 more


Related issues

Related to Edit - feature request #6737: Make error message available in "Copy Error" New 06/16/2017
Related to Edit - bug #6355: Improve message if server is down Duplicate 01/20/2017
Duplicated by Edit - feature request #5209: Improve server availability check New 09/08/2015

History

#1 Updated by Andreas Müller over 2 years ago

#2 Updated by Patrick Plitzner over 2 years ago

  • Related to bug #6355: Improve message if server is down added

#3 Updated by Patrick Plitzner over 2 years ago

  • Description updated (diff)

#4 Updated by Patrick Plitzner about 1 year ago

#5 Updated by Patrick Plitzner about 1 year ago

  • Status changed from New to Duplicate
  • Target version deleted (Unassigned CDM tickets)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)