Project

General

Profile

bug #6733

feature request #6565: [MASTER] Eclipse 4 Migration

feature request #6596: Migrate specimen editor

NPE when trying to open Derivative Editor

Added by Patrick Plitzner over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
06/16/2017
Due date:
% Done:

100%

Severity:
blocker
Found in Version:

Description

login : admin

editor version : 4.8.0.201706072259

server : test.e-taxonomy.eu (edit-test) / rem_conf_am

schema version : 4.7.0.0.201710040000

os : Windows Server 2012 R2 6.3 amd64

java : 1.8.0_121

org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException

                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)

                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)

                at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)

                at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)

                at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)

                at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)

                at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)

                at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)

                at org.eclipse.ui.internal.handlers.LegacyHandlerService.executeCommand(LegacyHandlerService.java:353)

                at eu.etaxonomy.taxeditor.view.CdmViewerContextMenu$CommandInvoker.widgetSelected(CdmViewerContextMenu.java:114)

                at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)

                at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

                at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)

                at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)

                at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)

                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)

                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)

                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)

                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)

                at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)

                at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)

                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)

                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)

                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)

                at eu.etaxonomy.taxeditor.Application.start(Application.java:24)

                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)

                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)

                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)

                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

                at java.lang.reflect.Method.invoke(Method.java:498)

                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)

                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)

                at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

Caused by: java.lang.NullPointerException

                at eu.etaxonomy.taxeditor.editor.view.derivate.handler.OpenDerivativeEditorForTaxonNode.open(OpenDerivativeEditorForTaxonNode.java:48)

                at eu.etaxonomy.taxeditor.editor.view.derivate.handler.OpenDerivativeEditorForTaxonNode.open(OpenDerivativeEditorForTaxonNode.java:1)

                at eu.etaxonomy.taxeditor.handler.defaultHandler.DefaultOpenHandlerBase.execute(DefaultOpenHandlerBase.java:30)

                at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:295)

                at org.eclipse.ui.internal.handlers.E4HandlerProxy.execute(E4HandlerProxy.java:90)

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

                at java.lang.reflect.Method.invoke(Method.java:498)

                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)

                ... 36 more

Associated revisions

Revision bb1d1762 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6733 Make model fragment IDs unique

Revision 9e1d7d77 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6733 Set apply time of model fragment to "always"

Revision 10f50c3f (diff)
Added by Patrick Plitzner over 1 year ago

ref #6733 Add model fragment to bin.includes

History

#1 Updated by Patrick Plitzner over 1 year ago

#2 Updated by Patrick Plitzner over 1 year ago

To correctly test this you have to delete {home}/.cdmLibrary/.metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi before testing. This file stores and caches the application model.

#3 Updated by Patrick Plitzner over 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 80

#4 Updated by Andreas Müller over 1 year ago

#5 Updated by Andreas Müller over 1 year ago

  • Status changed from Resolved to Closed
  • Parent task set to #6596

#6 Updated by Andreas Müller over 1 year ago

  • % Done changed from 80 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)