Project

General

Profile

Actions

bug #6707

closed

transient properties managed by ToManyRelatedEntitiesListSelect are not updated on save

Added by Andreas Kohlbecker over 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

The TaxonNamePopupEditor uses a ToManyRelatedEntitiesComboboxSelect to allow editing the associations to basionym names.
Changes are not saved, though.

The reason for this is that Vaadin MethodProperties are readonly when no setter is available, the commit of the ToManyRelatedEntitiesListSelect is not working in this case.


Related issues

Is duplicate of EDIT - task #7365: enable CdmPopupEditors to operate on CdmDecoratorDTOsClosedAndreas Kohlbecker

Actions
Is duplicate of EDIT - bug #7386: TaxonNamePopEditor: com.vaadin.data.Property$ReadOnlyException on saving a basionym ClosedAndreas Kohlbecker

Actions
Actions #1

Updated by Andreas Kohlbecker over 5 years ago

  • Description updated (diff)
Actions #2

Updated by Andreas Kohlbecker over 5 years ago

  • Subject changed from transient properties managed by ToManyRelatedEntitiesListSelect are not updaed on save to transient properties managed by ToManyRelatedEntitiesListSelect are not updated on save
Actions #3

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.9 to Release 4.10
Actions #4

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.10 to Release 4.11
Actions #5

Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 4.11 to Release 4.12
Actions #6

Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 4.12 to Release 4.13
Actions #7

Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 4.13 to Release 4.14
Actions #8

Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.14 to Release 5.0
Actions #9

Updated by Andreas Kohlbecker almost 5 years ago

  • Tags set to phycobank
Actions #10

Updated by Andreas Kohlbecker almost 5 years ago

  • Priority changed from New to Highest
Actions #11

Updated by Andreas Kohlbecker almost 5 years ago

  • Description updated (diff)
  • Status changed from New to Duplicate

this problem has been solved by using a TaxonNameDTO for the TaxonNameEditor. see #7365, #7386 and cdm-vaadin|c256784f

Actions #12

Updated by Andreas Kohlbecker almost 5 years ago

  • Is duplicate of task #7365: enable CdmPopupEditors to operate on CdmDecoratorDTOs added
Actions #13

Updated by Andreas Kohlbecker almost 5 years ago

  • Is duplicate of bug #7386: TaxonNamePopEditor: com.vaadin.data.Property$ReadOnlyException on saving a basionym added
Actions

Also available in: Atom PDF