Project

General

Profile

Actions

feature request #6693

closed

Implement missing nomenclatural codes for name detail element

Added by Patrick Plitzner about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
major

Description

in class eu.etaxonomy.taxeditor.ui.section.name.NameDetailElement

private void createSpecificNameParts(ICdmFormElement formElement,
            INonViralName nonViralName, int style) {
        NomenclaturalCode code = nonViralName.getNomenclaturalCode();
        if (code != null){
            switch(nonViralName.getNomenclaturalCode()){
            case ICNAFP :
                //nothing do add
                createBotanicalNameParts(formElement, nonViralName, style);
                break;
            case Fungi :
                if (isAdvancedView){
                    createFungusNameParts(formElement, nonViralName, style);
                }
                break;
            case ICZN:
                createZoologicalNameParts(formElement, nonViralName, style);
                break;
            case ICVCN:
                //TODO implement
                logger.warn("ICVCN not yet implemented");
                break;
            case ICNB:
                //TODO implement
                logger.warn("ICNB not yet implemented");
                break;
            case ICNCP:
                //TODO implement
                logger.warn("ICNCP not yet implemented");
                break;
            case NonViral:
                //TODO implement
                logger.warn("NonViral not yet implemented");
                break;
            }
        }
    }

Files

picture96-1.png (2.25 KB) picture96-1.png Andreas Müller, 09/18/2017 03:27 PM

Related issues

Related to EDIT - feature request #6692: Make name types changeableClosedKatja Luther

Actions
Related to EDIT - feature request #6957: Implement cache strategy for viral namesClosedAndreas Müller

Actions
Related to EDIT - feature request #6963: Implement cache strategy for cultivar plant names (done), bacterial names, fungi, etc.In ProgressAndreas Müller

Actions
Related to EDIT - feature request #6361: [MASTER] Merge all TaxonName classes into 1 class ClosedAndreas Müller

Actions
Is duplicate of EDIT - feature request #6691: Implement all name types in NameDetailElementDuplicateKatja Luther

Actions
Copied to EDIT - feature request #6950: Alllow the usage of Viral NamesNewKatja Luther

Actions
Actions #1

Updated by Patrick Plitzner about 5 years ago

Actions #3

Updated by Katja Luther almost 5 years ago

  • Status changed from New to Resolved
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 4.10

added the missing nomenclatural codes, removed the viral code because it causes a NPE. Create a new ticket for details view for viral names (#6950)

Actions #4

Updated by Andreas Müller almost 5 years ago

Actions #5

Updated by Andreas Müller almost 5 years ago

Katja Luther wrote:

removed the viral code because it causes a NPE

Can you please commit this, otherwise I can't test

Actions #6

Updated by Katja Luther almost 5 years ago

is already commited in Revision 80c710e0, see above

Actions #7

Updated by Andreas Müller almost 5 years ago

Katja Luther wrote:

is already commited in Revision 80c710e0, see above

But this version still allows choosing ICVCN (however I currently work on the CacheStrategy update, maybe this is sufficient)

Actions #8

Updated by Katja Luther almost 5 years ago

sorry, I missed to commit it on friday, it was committed three hours ago.

Actions #9

Updated by Andreas Müller almost 5 years ago

Katja Luther wrote:

sorry, I missed to commit it on friday, it was committed three hours ago.

But ICVCN is STILL available in the very latest version build 20 min ago! See attachement.

Please test with nightly.

Actions #10

Updated by Katja Luther almost 5 years ago

  • % Done changed from 0 to 50
Actions #11

Updated by Andreas Müller almost 5 years ago

Actions #12

Updated by Andreas Müller almost 5 years ago

Actions #13

Updated by Andreas Müller almost 5 years ago

Actions #14

Updated by Andreas Müller almost 5 years ago

Is it possible to move the "Name approbation" for bacterial names either up below "LSID" or if this is not possible down below "Appended Phrase" as it is not part of the name but more an explanation.

Actions #15

Updated by Andreas Müller almost 5 years ago

Andreas Müller wrote:

Is it possible to move the "Name approbation" for bacterial names either up below "LSID" or if this is not possible down below "Appended Phrase" as it is not part of the name but more an explanation.

Once this is implemented we can close this ticket from my side. We still need better cache strategies for the "new" codes but this is not part of this ticket.

Actions #16

Updated by Andreas Müller almost 5 years ago

  • Related to feature request #6963: Implement cache strategy for cultivar plant names (done), bacterial names, fungi, etc. added
Actions #17

Updated by Andreas Müller almost 5 years ago

Actions #18

Updated by Andreas Müller almost 5 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Patrick Plitzner to Katja Luther
  • Severity changed from normal to major

One more issue, which is a bit critical: we currently do have a hard validation if a name contains only data which is according to its code. E.g. a ICNAFP name must not have "acronym" or "nameApprobation" set. Otherwise one gets an validation exception and the name is not saved.

Therefore we need to delete these fields once the name type is changed. However, this is a bit critical if one changes the type only accidentally and changes it back afterwards. This will lead to a loss of data, maybe even not recognized by the user.
Therefore the better solution might be to run this check immediately before saving.

Another solution could be to remove this hard validation, but this may lead to dirty data. Also not nice.

Actions #19

Updated by Katja Luther almost 5 years ago

Actions #20

Updated by Katja Luther almost 5 years ago

  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

One more issue, which is a bit critical: we currently do have a hard validation if a name contains only data which is according to its code. E.g. a ICNAFP name must not have "acronym" or "nameApprobation" set. Otherwise one gets an validation exception and the name is not saved.

Therefore we need to delete these fields once the name type is changed. However, this is a bit critical if one changes the type only accidentally and changes it back afterwards. This will lead to a loss of data, maybe even not recognized by the user.
Therefore the better solution might be to run this check immediately before saving.

Another solution could be to remove this hard validation, but this may lead to dirty data. Also not nice.

But if you change the type accidentally, you are not able to save the taxon, so you have to delete the name approbiation before you are able to change the type and loose the data.

Actions #21

Updated by Katja Luther almost 5 years ago

Andreas Müller wrote:

One more issue, which is a bit critical: we currently do have a hard validation if a name contains only data which is according to its code. E.g. a ICNAFP name must not have "acronym" or "nameApprobation" set. Otherwise one gets an validation exception and the name is not saved.

Therefore we need to delete these fields once the name type is changed. However, this is a bit critical if one changes the type only accidentally and changes it back afterwards. This will lead to a loss of data, maybe even not recognized by the user.
Therefore the better solution might be to run this check immediately before saving.

Another solution could be to remove this hard validation, but this may lead to dirty data. Also not nice.

Now a dialog pops up to confirm the deletion of the nametype specific parts.

Actions #22

Updated by Katja Luther almost 5 years ago

  • Status changed from Feedback to Resolved
Actions #23

Updated by Andreas Müller almost 5 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

It seems to be available only for "Name Approbation". But it should be available for all attributes which are not available in the new code.

Actions #24

Updated by Katja Luther almost 5 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

It seems to be available only for "Name Approbation". But it should be available for all attributes which are not available in the new code.

subGenusAuthor was missing. For the other codes all attributes are checked.

Actions #25

Updated by Andreas Müller almost 5 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

It is still missing for "anamorphic" when changing from "Fungi" to e.g. ICNAFP. Anamorphic must not be true for any other code then Fungi.

Actions #26

Updated by Andreas Müller almost 5 years ago

All the rest seems to work as expected.

Actions #27

Updated by Katja Luther almost 5 years ago

  • Status changed from Feedback to Resolved
Actions #28

Updated by Katja Luther almost 5 years ago

  • Status changed from Resolved to Feedback

Andreas Müller wrote:

It is still missing for "anamorphic" when changing from "Fungi" to e.g. ICNAFP. Anamorphic must not be true for any other code then Fungi.

I implemented it the oher way round. is fixed

Actions #29

Updated by Andreas Müller almost 5 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

This is now fully fixed

Actions

Also available in: Atom PDF