Project

General

Profile

Actions

bug #6683

closed

Use best quality media representation in image viewer on media page

Added by Andreas Kohlbecker almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
blocker
Found in Version:
Tags:

Description

The image viewer in the media page always chooses only the first representation even if this is a thumbnail image. The representation with the best quality should be used instead.

See for example: http://portal.cybertaxonomy.org/flora-greece/cdm_dataportal/media/fb1a93d9-8c90-4b35-a1ea-be0e176facac


Related issues

Related to EDIT - bug #6969: Use media representation which best fits the available size for taxon profile pictureClosedAndreas Kohlbecker

Actions
Related to EDIT - bug #6970: MediaUtils.filterAndOrderMediaRepresentations perfers thumbnail MediaRepresentations over full sizedClosedAndreas Kohlbecker

Actions
Blocked by EDIT - bug #6684: Use media representation which best fits the available viewport size for the Image Overlay ClosedAndreas Kohlbecker

Actions
Actions #1

Updated by Andreas Müller almost 5 years ago

  • Target version changed from cdm_dataportal - Next Major Release to Unassigned CDM tickets
Actions #2

Updated by Andreas Kohlbecker almost 5 years ago

  • Related to bug #6684: Use media representation which best fits the available viewport size for the Image Overlay added
Actions #3

Updated by Andreas Kohlbecker almost 5 years ago

  • Target version changed from Unassigned CDM tickets to Release 4.8
  • Severity changed from normal to blocker
Actions #4

Updated by Andreas Kohlbecker almost 5 years ago

  • Priority changed from New to Highest
Actions #5

Updated by Andreas Kohlbecker almost 5 years ago

  • Description updated (diff)
Actions #6

Updated by Andreas Kohlbecker almost 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50
Actions #7

Updated by Andreas Kohlbecker almost 5 years ago

  • Target version changed from Release 4.8 to Release 4.9
Actions #8

Updated by Andreas Kohlbecker almost 5 years ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller

I cant really do the review since the flora of greece portal still is using the full-size images as thumbnails.
Andreas Müller: please review once the thumbnails are back

Actions #9

Updated by Andreas Müller almost 5 years ago

Andreas Kohlbecker wrote:

I cant really do the review since the flora of greece portal still is using the full-size images as thumbnails.
Andreas Müller: please review once the thumbnails are back

The problem is that the images can't be switched back as long as #6684 is not fixed. Otherwise they may show up in thumbnail size in overlay.

Actions #10

Updated by Andreas Müller almost 5 years ago

  • Related to deleted (bug #6684: Use media representation which best fits the available viewport size for the Image Overlay )
Actions #11

Updated by Andreas Müller almost 5 years ago

  • Blocked by bug #6684: Use media representation which best fits the available viewport size for the Image Overlay added
Actions #12

Updated by Andreas Müller over 4 years ago

  • Related to bug #6969: Use media representation which best fits the available size for taxon profile picture added
Actions #13

Updated by Andreas Müller over 4 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Andreas Kohlbecker
  • % Done changed from 50 to 100

This also seems to work I tested yesterday together with #6684

Actions #14

Updated by Andreas Kohlbecker about 2 years ago

  • Related to bug #6970: MediaUtils.filterAndOrderMediaRepresentations perfers thumbnail MediaRepresentations over full sized added
Actions

Also available in: Atom PDF