Project

General

Profile

bug #6530

After editing a nomenclatural reference of a new created name some information is lost

Added by Katja Luther over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
03/22/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

Creating a new name and edit the nomenclatural reference before the name is saved does not work.
if the nomenclatural reference is an article with an inreferenced journal the nomenclatural reference is now the journal.

Associated revisions

Revision dcff61a3 (diff)
Added by Katja Luther over 1 year ago

fix #6530: save the unpersisted entity before closing EditFromSelectionWizard

History

#1 Updated by Andreas Müller over 1 year ago

  • Target version changed from Unassigned CDM tickets to Release 4.7

#2 Updated by Andreas Müller over 1 year ago

WBG:

ich habe einen merkwürdigen Bug gefunden, den es (glaube ich) früher nicht gab. Tritt jetzt zum 2. Mal auf, das erste Mal dachte ich, ich hätte etwas versäumt.
Mein Vorgehen:
Neuen Namen erzeugt; Nomenklaturreferenz im Name Editor hinzugefügt.
Nepenthes samar Jebb & Cheek in Blumea 58(1): 82. 2013
Soweit alles klar.
Dann gehe ich im Details View auf die Nomenclatural Referenz und editiere die – füge den Titel des Artikels, den Seitenzahlbereich und eine URI zum online-Artikel hinzu.
Finish -> Alles bis auf den Periodical Titel weg; wenn ich wieder auf Edit gehe, zeigt er mir auch das Journal an.
Die Artikel-Referenz ist auch nach Re-connect nicht mehr zu finden.
Nochmal gemacht, aber vorher das Taxon gespeichert, vielleicht lag es daran? Dann alles normal.

#3 Updated by Katja Luther over 1 year ago

  • Status changed from New to Worksforme

Could not reproduce it anymore.

#4 Updated by Katja Luther over 1 year ago

  • Status changed from Worksforme to In Progress

#5 Updated by Katja Luther over 1 year ago

Katja Luther wrote:

Could not reproduce it anymore.

if the taxon is not saved before editing the reference the problem appears.

#6 Updated by Katja Luther over 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

#7 Updated by Katja Luther over 1 year ago

  • % Done changed from 50 to 0

The problem is that if the object loaded in the details wizard has id = 0.
When the wizard is closed, it is not saved. Then the object with cacheID reference0 is loaded from the cache and set to the selectionEntity, but the journal has also the cacheid reference0 so the journal is loaded.
Now the entity is saved and this is loaded to the previousCdmEntitySession.

#8 Updated by Katja Luther over 1 year ago

  • Assignee changed from Katja Luther to Andreas Müller

please review

#9 Updated by Andreas Müller over 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 100

Looks fine now. And it seems to be the correct way to always store all data edited in a dialog.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)