Project

General

Profile

Actions

feature request #6483

closed

Restructure "Show view" and bulk editor menu

Added by Patrick Plitzner over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
New
Assignee:
Patrick Plitzner
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

50%

Estimated time:
Severity:
normal

Related issues

Related to EDIT - bug #6498: Refactor dynamic bulk editor menu into a declarative oneNewKatja Luther

Actions
Has duplicate EDIT - task #6271: Move user and user groups from bulk editor menu to Admin menuDuplicateKatja Luther

Actions
Is duplicate of EDIT - task #6474: Move Specimen-Editor to bulk editor menuDuplicatePatrick Plitzner

Actions
Actions #1

Updated by Patrick Plitzner over 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50
Actions #2

Updated by Patrick Plitzner over 5 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller
Actions #3

Updated by Andreas Müller over 5 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Looks good.
Can we still add separators in Admin menu to separate the user management menu items from others?

Also use capital letters for both "Bulk" and "Hierarchie" (or if you prefer for none). I only checked German version but please also handle English version consistent if necessary.

Actions #4

Updated by Andreas Müller over 5 years ago

Also we could move "Media" down in the menu as it is less important than specimen.

Actions #5

Updated by Andreas Müller over 5 years ago

  • Has duplicate task #6271: Move user and user groups from bulk editor menu to Admin menu added
Actions #6

Updated by Patrick Plitzner over 5 years ago

  • Is duplicate of task #6474: Move Specimen-Editor to bulk editor menu added
Actions #7

Updated by Patrick Plitzner over 5 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Moving media down unfortunately is not that easy because the bulk editor menu is dynamic making it hard to reference the items within the menu from other extension points.
I propose we close this ticket and if we have time we can maybe refactor the bulk editor menu to be declarative.

Actions #8

Updated by Andreas Müller over 5 years ago

Ok. Can you close this ticket and open the new one for refactoring?

Actions #9

Updated by Andreas Müller over 5 years ago

  • Assignee changed from Andreas Müller to Patrick Plitzner
Actions #10

Updated by Patrick Plitzner over 5 years ago

  • Related to bug #6498: Refactor dynamic bulk editor menu into a declarative one added
Actions #11

Updated by Patrick Plitzner over 5 years ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF