Project

General

Profile

Actions

bug #6333

closed

Add existing media to a taxon description is not persisted

Added by Katja Luther about 6 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

When adding an existing media to a taxon the description shows up correctly, but after changing the view and come back to the media view the selected media is not shown anymore and it is not possible to save it.

Actions #1

Updated by Patrick Plitzner about 6 years ago

  • Status changed from New to In Progress
  • Target version changed from Unassigned CDM tickets to Release 4.5
Actions #2

Updated by Patrick Plitzner about 6 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther

I removed the option to change an existing media element in the DetailsView. Instead we should add the option to add existing media when creating the element. This was already implemented in e.g. the Media view and in the Specimen Editor. I added generic support to do so to the entity collection section super class and implemented it for the media collection section. Adding existing media should now be possible in the Specimen Editor, the media view and in the supplemental data view for e.g. Persons.

Actions #3

Updated by Andreas Müller 11 months ago

  • Subject changed from add existing media to a taxon description is not persisted to Add existing media to a taxon description is not persisted
  • Description updated (diff)
  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

The solution sounds reasonable and it seems to work.

Actions

Also available in: Atom PDF