Project

General

Profile

Actions

bug #6317

closed

LIE during request to portal/taxon/find.json

Added by Andreas Kohlbecker about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
New
Category:
cdmlib-remote
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

http://api.cybertaxonomy.org/salvador/portal/taxon/find.json?doTaxaByCommonNames=1&doMisappliedNames=1&doSynonyms=1&doTaxa=1&pageNumber=0&pageSize=25&query=Tecoma&tree=b010c84d-6049-45f4-9f13-c065101eaa26

Caused by: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.agent.Team.teamMembers, could not initialize proxy - no Session
    at org.hibernate.collection.internal.AbstractPersistentCollection.throwLazyInitializationException(AbstractPersistentCollection.java:567)
    at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:205)
    at org.hibernate.collection.internal.AbstractPersistentCollection.initialize(AbstractPersistentCollection.java:546)
    at org.hibernate.collection.internal.AbstractPersistentCollection.read(AbstractPersistentCollection.java:133)
    at org.hibernate.collection.internal.PersistentList.iterator(PersistentList.java:132)
    at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getTitleCache(TeamDefaultCacheStrategy.java:89)
    at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getTitleCache(TeamDefaultCacheStrategy.java:1)
    at eu.etaxonomy.cdm.model.common.IdentifiableEntity.generateTitle(IdentifiableEntity.java:677)
    at eu.etaxonomy.cdm.model.agent.Team.getTitleCache(Team.java:301)
    at eu.etaxonomy.cdm.remote.json.processor.bean.TeamOrPersonBaseBeanProcessor.processBeanSecondStep(TeamOrPersonBaseBeanProcessor.java:40)
    at eu.etaxonomy.cdm.remote.json.processor.bean.TeamOrPersonBaseBeanProcessor.processBeanSecondStep(TeamOrPersonBaseBeanProcessor.java:23)
    at eu.etaxonomy.cdm.remote.json.processor.bean.AbstractBeanProcessor.processBean(AbstractBeanProcessor.java:168)
    at net.sf.json.JSONObject._fromBean(JSONObject.java:676)

Related issues

Related to EDIT - bug #4377: LazyInitializationException (LIE) related to Team.teamMembers when calling portal/taxon.jsonClosedAndreas Kohlbecker

Actions
Actions #1

Updated by Andreas Kohlbecker about 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50
Actions #2

Updated by Andreas Kohlbecker about 6 years ago

  • Related to bug #4377: LazyInitializationException (LIE) related to Team.teamMembers when calling portal/taxon.json added
Actions #3

Updated by Andreas Kohlbecker about 6 years ago

  • Related to deleted (bug #4377: LazyInitializationException (LIE) related to Team.teamMembers when calling portal/taxon.json)
Actions #4

Updated by Andreas Kohlbecker about 6 years ago

  • Is duplicate of bug #4377: LazyInitializationException (LIE) related to Team.teamMembers when calling portal/taxon.json added
Actions #5

Updated by Andreas Kohlbecker about 6 years ago

  • Is duplicate of deleted (bug #4377: LazyInitializationException (LIE) related to Team.teamMembers when calling portal/taxon.json)
Actions #6

Updated by Andreas Kohlbecker about 6 years ago

  • Related to bug #4377: LazyInitializationException (LIE) related to Team.teamMembers when calling portal/taxon.json added
Actions #7

Updated by Andreas Kohlbecker about 6 years ago

  • Status changed from Resolved to Closed
Actions #8

Updated by Andreas Müller over 5 years ago

  • % Done changed from 50 to 100
Actions

Also available in: Atom PDF