Project

General

Profile

feature request #6308

Add configuration dialog for the deletion of synonyms in name editor

Added by Katja Luther almost 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
01/03/2017
Due date:
% Done:

90%

Estimated time:
1.50 h
Severity:
normal

Description

for the deletion of synonyms we also need a configuration dialog, similar to the deletion of taxa.


Related issues

Related to Edit - bug #6219: Deleting synonym is persisted immediately, but the editor is set dirty Closed 11/24/2016
Related to Edit - bug #9398: ObjectNotFoundException when removing a synonym that is used as NameInSource Closed 01/18/2021

Associated revisions

Revision 2bffeed2 (diff)
Added by Katja Luther almost 5 years ago

fix #6308: add delete configuration dialog for synonyms and misapplied names

Revision 7b179f56 (diff)
Added by Katja Luther over 4 years ago

fix #6308: fix correct deletion handling of synonyms and misapplications and the right messages when delete a synonym with not deletable name

History

#1 Updated by Katja Luther almost 5 years ago

  • Related to bug #6219: Deleting synonym is persisted immediately, but the editor is set dirty added

#2 Updated by Andreas Müller almost 5 years ago

  • Subject changed from Add configuration dioalog for the deletion of synonyms in name editor to Add configuration dialog for the deletion of synonyms in name editor
  • Target version changed from Unassigned CDM tickets to Release 4.5
  • Estimated time set to 1.50 h

#3 Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.5 to Release 4.6

#4 Updated by Katja Luther almost 5 years ago

  • Priority changed from New to Highest

#5 Updated by Katja Luther almost 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#6 Updated by Katja Luther almost 5 years ago

  • Assignee changed from Katja Luther to Andreas Müller

#7 Updated by Andreas Müller almost 5 years ago

Generally works, but if name could not be deleted (because in use) 2 warning appear, first is about synonym delete, second about misapplication delete.

Maybe also #6424 is a related issue or even a regression

#8 Updated by Andreas Müller almost 5 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

#9 Updated by Andreas Müller almost 5 years ago

  • Tracker changed from bug to feature request

#10 Updated by Katja Luther over 4 years ago

  • Status changed from Feedback to Resolved

#11 Updated by Katja Luther over 4 years ago

  • Assignee changed from Katja Luther to Andreas Müller

#12 Updated by Andreas Müller 11 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 90

The 2 warnings do not show up anymore so we can close this ticket.
However, I am a bit astonished that no warning exists at all. I thought I remembered that if the name can not be deleted a warning/message appears that it could not be deleted. However, this is not the case anymore. I tested also for deleting a TaxonNode with a name that is in use and also not warning exists anymore so this issue does not seem to be only a synonym name issue.

If the obeserved behavior is the expected behavior feel free to close the ticket.

#13 Updated by Andreas Müller 11 months ago

  • Related to bug #9398: ObjectNotFoundException when removing a synonym that is used as NameInSource added

#14 Updated by Katja Luther 11 months ago

  • Status changed from Feedback to Closed

Andreas Müller wrote:

The 2 warnings do not show up anymore so we can close this ticket.
However, I am a bit astonished that no warning exists at all. I thought I remembered that if the name can not be deleted a warning/message appears that it could not be deleted. However, this is not the case anymore. I tested also for deleting a TaxonNode with a name that is in use and also not warning exists anymore so this issue does not seem to be only a synonym name issue.

If the obeserved behavior is the expected behavior feel free to close the ticket.

now isDeletable checks also for name isDeletable and adds a warning if name can't be deleted.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)