Project

General

Profile

Actions

bug #6287

closed

Rolling cdmserver.log file only contains entries from startup phase

Added by Andreas Kohlbecker about 5 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Priority14
Category:
cdmserver
Target version:
-
Start date:
12/19/2016
Due date:
% Done:

0%

Estimated time:
Severity:
normal
Found in Version:

Description

The last entry in the cdmserver.log always is:

... INFO [eu.etaxonomy.cdm.server.instance.CdmInstance] - lifeCycleStarted

the logging is only received by the console logger.

The cdmserver.log is hard coded in the Booloader class. preferably the logger should be configured in the log4j.properties.

see http://www.eclipse.org/jetty/documentation/current/configuring-logging-modules.html#_capturing_console_output

for details.


Related issues

Related to Edit - feature request #6249: better logging strategyClosedAndreas Kohlbecker12/06/2016

Actions
Is duplicate of Edit - bug #7085: cdmserver logfiles getting too big, use RollingFileAppender ClosedAndreas Kohlbecker11/23/2017

Actions
Actions #1

Updated by Andreas Kohlbecker about 5 years ago

  • Subject changed from cdmserver.log only contains entries from startup phase to Rolling cdmserver.log file only contains entries from startup phase
  • Description updated (diff)

The logging into files needs to be configured to jetty:

http://www.eclipse.org/jetty/documentation/current/configuring-logging.html#configuring-jetty-logging

by default jetty will default to using an internal org.eclipse.jetty.util.log.StdErrLog implementation. This will output all logging events to STDERR (aka System.err). which will be written into out.log

Actions #2

Updated by Andreas Kohlbecker about 5 years ago

Actions #3

Updated by Andreas Kohlbecker about 5 years ago

  • Target version changed from cdmlib - Old Next Major Release to Reviewed Next Major Release
Actions #4

Updated by Andreas Kohlbecker over 3 years ago

  • Description updated (diff)
Actions #5

Updated by Patrick Plitzner over 3 years ago

  • Assignee changed from Andreas Kohlbecker to Patrick Plitzner
  • Target version changed from Reviewed Next Major Release to Release 5.4
Actions #6

Updated by Patrick Plitzner over 3 years ago

  • Related to bug #7085: cdmserver logfiles getting too big, use RollingFileAppender added
Actions #7

Updated by Patrick Plitzner over 3 years ago

  • Status changed from New to Closed
  • Assignee changed from Patrick Plitzner to Andreas Kohlbecker
  • % Done changed from 0 to 100

This is fixed by fixing #7085

Actions #8

Updated by Andreas Kohlbecker about 3 years ago

  • Status changed from Closed to In Progress
  • Target version changed from Release 5.4 to Release 5.5
  • % Done changed from 100 to 0
Actions #9

Updated by Andreas Kohlbecker almost 3 years ago

  • Target version changed from Release 5.5 to Release 5.6
Actions #10

Updated by Andreas Kohlbecker almost 3 years ago

  • Target version changed from Release 5.6 to Reviewed Next Major Release
Actions #11

Updated by Andreas Kohlbecker over 1 year ago

  • Status changed from In Progress to Duplicate
  • Target version deleted (Reviewed Next Major Release)

this has been solved by #7085

Closing as duplicate

Actions #12

Updated by Andreas Kohlbecker over 1 year ago

  • Related to deleted (bug #7085: cdmserver logfiles getting too big, use RollingFileAppender )
Actions #13

Updated by Andreas Kohlbecker over 1 year ago

  • Is duplicate of bug #7085: cdmserver logfiles getting too big, use RollingFileAppender added
Actions

Also available in: Atom PDF