Project

General

Profile

bug #6244

Sortindex problems in complex operations like swap synonym and accepted and others

Added by Katja Luther over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
cdmlib
Target version:
Start date:
12/06/2016
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

Norbert hatte gerade ein Problem. Er hat bei einer Subspezies diese zuerste mit einem Synonym (einer Spezies) getauscht mit der Swap Funktion.

Danach hat er versucht die (neue) akzeptierte Art an die Gattung zu hängen (da es ja vorher eine Unterart war, hing die neue Art jetzt an einer anderen Art als Kind, was natürlich falsch war).

Bei einer dieser beiden Prozeduren scheint der sortindex kaputt gegangen zu sein und zwar so, dass bei den Unterarten der alten Art ein Sortindex 2 mal vorkam (also 0,1,2,2,3). Auf Artebene fehlte ein sortindex ganz und einer anderer kam doppelt vor.

Das führte zwar nicht zu Exceptions aber zu undefiniertem Verhalten. Irgendetwas fehlte immer, jedoch bei Norbert anders als bei mir und auch im Portal wieder anders.


Related issues

Related to Edit - feature request #4766: Repair Methods for the cdm instance Closed 03/31/2015

Associated revisions

Revision 6e700142 (diff)
Added by Katja Luther over 2 years ago

fix #6244: add removeNullValues in updateSortindex method to avoid exception when collection contains null values

Revision fcd142d1 (diff)
Added by Katja Luther over 2 years ago

fix #6244: add removeNullValues in updateSortindex method to avoid exception when collection contains null values

History

#1 Updated by Katja Luther over 2 years ago

The problems seem to be caused by the call of updateSortindex when the collection contains null values. Then the method breaks and the remaining elements of the collections are not handled anymore.

I added the call of HHH_9751_Util.removeAllNull() in the updateSortindex() method to avoid this.

#2 Updated by Andreas Müller over 2 years ago

#3 Updated by Katja Luther over 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#4 Updated by Katja Luther over 2 years ago

  • Assignee changed from Katja Luther to Andreas Müller

#5 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 4.5 to Release 4.4

This was part of the bugfix release as far as I remember

#6 Updated by Andreas Müller over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • Found in Version set to Release 4.4

As this is lot of work to test but we did not get any complaints anymore I close without final testing. Also we do have the sortIndex updater in Admin menu now which helps solving issues in case they appear again.

#7 Updated by Andreas Müller over 2 years ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)