Project

General

Profile

bug #6235

bug #6115: protect cdm content by drupal permission

page duplication when accessing resticted content

Added by Andreas Kohlbecker over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Highest
Category:
cdm-dataportal
Target version:
-
Start date:
12/01/2016
Due date:
% Done:

0%

Severity:
blocker
Found in Version:

Description

At least in the flora-cuba portal there is strange effect when accessing a taxon page without sufficient permissions.
The page appeares duplicated the upper part of the browser window shows the access denied page and the lower part exposes the content which should be restricted!

Test url: http://edit.dev/d7/flora-cuba/cdm_dataportal/taxon/7beb8ef0-5878-4937-874e-bf0fa4f97c6b

access-denied-page-duplication.png View (384 KB) Andreas Kohlbecker, 12/01/2016 05:44 PM

History

#1 Updated by Andreas Kohlbecker over 2 years ago

  • Parent task set to #6115

#3 Updated by Andreas Kohlbecker over 2 years ago

  • Description updated (diff)

#4 Updated by Andreas Kohlbecker over 2 years ago

  • Status changed from New to Rejected
  • Target version deleted (Release 4.4)

This is not a problem in the code. The observed effect was caused by pending updates for the cdm_dataportal module and by the need to flush the drupal cache in order to refresh the menu and pages.This is done automatically in the test and production portals so that the problem should not occure there.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)