Project

General

Profile

Actions

bug #6228

closed

Fix behavior of multi-language editing

Added by Andreas Müller about 6 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

90%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

As realized in #6199 multi-language editing does not work correctly yet.
Adding >2 languages, deletes one of the old descriptions so that always only 2 languages remain.
This happens only when saving, while an unsaved TextData shows all existing translations.

Also the behavior of the Translation editor is strange. With a choosen language one would expect that this language is shown on the right side after opening the Editor, but it always shows no language. One first has to choose the language to translate.

Also it is currently impossible to delete a language.

Partly these issues have been solved for the Term Editor already, but there the data structure is a bit different.


Files

clipboard-202209140011-vherv.png (4.29 KB) clipboard-202209140011-vherv.png Andreas Müller, 09/14/2022 12:11 AM
clipboard-202210071250-8tsr0.png (8.09 KB) clipboard-202210071250-8tsr0.png Andreas Müller, 10/07/2022 12:50 PM

Related issues

Follows EDIT - bug #6199: Excluded note for excluded taxon nodes in TaxEdtiorClosedPatrick Plitzner

Actions
Precedes EDIT - bug #6229: Implement multi-language support for MultiLanguage textes everywhereNewKatja Luther

Actions
Actions #1

Updated by Andreas Müller about 6 years ago

  • Due date set to 12/01/2016
  • Start date changed from 11/30/2016 to 12/01/2016
  • Follows bug #6199: Excluded note for excluded taxon nodes in TaxEdtior added
Actions #2

Updated by Andreas Müller about 6 years ago

  • Precedes bug #6229: Implement multi-language support for MultiLanguage textes everywhere added
Actions #7

Updated by Katja Luther 6 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.33

The issue that only two languages are saved is solved in the meanwhile, the missing deletion was added with the last commit.

Actions #8

Updated by Katja Luther 6 months ago

  • Status changed from New to In Progress
Actions #9

Updated by Andreas Müller 5 months ago

  • Status changed from In Progress to Resolved
  • Priority changed from New to Highest
Actions #10

Updated by Katja Luther 5 months ago

  • Assignee changed from Katja Luther to Andreas Müller

please review

Actions #11

Updated by Katja Luther 5 months ago

  • % Done changed from 0 to 50
Actions #12

Updated by Andreas Müller 5 months ago

  • Tags set to i18n
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Most of the issues are fixed. It is now possible to add >2 languages and to remove a certain translation. This works.

What I do not understand is why it is possible to select from NO language both in the details view and in the translation editor. Was there a usecase for this?

Also I would expect that the translation editor opens in the language that was chosen in the details view before which is not the case.

However, these 2 issues are minor and may become obsolet once we unify and refactor the i18n handling in all classes in CDM. Therefore we may implement this now only if it is a no-brainer. Otherwise create a ticket with i18n tag.

Actions #13

Updated by Katja Luther 5 months ago

Andreas Müller wrote in #note-12:

Most of the issues are fixed. It is now possible to add >2 languages and to remove a certain translation. This works.

What I do not understand is why it is possible to select from NO language both in the details view and in the translation editor. Was there a usecase for this?

This is fixed.

Also I would expect that the translation editor opens in the language that was chosen in the details view before which is not the case.

The language on the left hand side is always the default language if exist, otherwise the "next" language. I think that the default language is on the left hand side and the "translation" on the right hand side was discussed like that years ago, but maybe I'm wrong.

To change the implementation of the translation wizard should be an extra ticket, because it needs more time.

However, these 2 issues are minor and may become obsolet once we unify and refactor the i18n handling in all classes in CDM. Therefore we may implement this now only if it is a no-brainer. Otherwise create a ticket with i18n tag.

Actions #14

Updated by Katja Luther 5 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
Actions #15

Updated by Andreas Müller 5 months ago

Katja Luther wrote in #note-13:

Andreas Müller wrote in #note-12:

What I do not understand is why it is possible to select from NO language both in the details view and in the translation editor. Was there a usecase for this?

This is fixed.

I still have the NO language entries in the translation editor:

Actions #16

Updated by Andreas Müller 5 months ago

  • % Done changed from 50 to 60

Katja Luther wrote in #note-13:

Andreas Müller wrote in #note-12:

Also I would expect that the translation editor opens in the language that was chosen in the details view before which is not the case.

The language on the left hand side is always the default language if exist, otherwise the "next" language. I think that the default language is on the left hand side and the "translation" on the right hand side was discussed like that years ago, but maybe I'm wrong.

To change the implementation of the translation wizard should be an extra ticket, because it needs more time.

OK, probably you are right. Anyway this will change in future so it will not make much sense to spend time on this now.

Actions #17

Updated by Katja Luther 5 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

The language combos are without the empty line now.

Actions #18

Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Everything works correct now except for the ride side of the translation editor

  1. When opening the trans-editor there is always the first language shown in the language selection combo. But even if a translation already exists for this language it is not shown.

  2. If a translation was chosen in the details view this languages translation/language should be chosen on the right side

  3. (only if easy to implement as this will change in future): don't show the language that is selected on the left side as it doesn't make sense to have the same languages on both sides (but have in mind that language can be changed on the left side, too, therefore I guess we may not want to implement this now as it is maybe complicated and behavior will change in future)

  4. We may also discuss which language should be shown if in details view the default language was selected and if the first language in the combo does not have a translation yet but if there is a translation for another language. Maybe in this case we should select the first language with an available translation instead of simply the first language; but this is also only nice to have and not necessary if not fast to implement

Actions #19

Updated by Katja Luther 4 months ago

Andreas Müller wrote in #note-18:

Everything works correct now except for the ride side of the translation editor

  1. When opening the trans-editor there is always the first language shown in the language selection combo. But even if a translation already exists for this language it is not shown. -> fixed

  2. If a translation was chosen in the details view this languages translation/language should be chosen on the right side -> fixed

  3. (only if easy to implement as this will change in future): don't show the language that is selected on the left side as it doesn't make sense to have the same languages on both sides (but have in mind that language can be changed on the left side, too, therefore I guess we may not want to implement this now as it is maybe complicated and behavior will change in future) -> it is not as easy as it seems, so I would do that later

  4. We may also discuss which language should be shown if in details view the default language was selected and if the first language in the combo does not have a translation yet but if there is a translation for another language. Maybe in this case we should select the first language with an available translation instead of simply the first language; but this is also only nice to have and not necessary if not fast to implement -> this is implemented

Actions #20

Updated by Andreas Müller 4 months ago

for review?

Actions #21

Updated by Katja Luther 4 months ago

Andreas Müller wrote in #note-20:

for review?

maybe I will have a look with nightly before.

Actions #22

Updated by Katja Luther 4 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

Katja Luther wrote in #note-21:

Andreas Müller wrote in #note-20:

for review?

maybe I will have a look with nightly before.

now, the issues mentioned above, are fixed now.

Actions #23

Updated by Andreas Müller 4 months ago

More or less everything is fixed (except for the filter for the default language as mentioned above).

Only I wonder, why the default language now always appears on top in the dropdown on the right side:

This is outside the alphabetic order which is valid for the remaining languages.

I suggest to fix the only if it is really fast to fix. Otherwise it is of very minor importance and we should concentrate on more important issues. It will change in future anyway when i18n is reimplemented in model.

Feel free to close immediately or fix remaining issue if fast.

Actions #24

Updated by Katja Luther 4 months ago

  • Status changed from Feedback to Closed

Andreas Müller wrote in #note-23:

More or less everything is fixed (except for the filter for the default language as mentioned above).

Only I wonder, why the default language now always appears on top in the dropdown on the right side:

This is outside the alphabetic order which is valid for the remaining languages.

I suggest to fix the only if it is really fast to fix. Otherwise it is of very minor importance and we should concentrate on more important issues. It will change in future anyway when i18n is reimplemented in model.

Feel free to close immediately or fix remaining issue if fast.

I can not reproduce this with nightly. So I would close this ticket.

Actions

Also available in: Atom PDF