Project

General

Profile

bug #6206

Vaadin view fail with: Failed to load the bootstrap javascript

Added by Patrick Plitzner over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
New
Category:
architecture
Target version:
Start date:
11/17/2016
Due date:
% Done:

100%

Severity:
blocker
Found in Version:

Description

When testing any vaadin view the following error is shown

Failed to load the bootstrap javascript: ./../VAADIN/vaadinBootstrap.js?v=7.6.3

The cause for this problem is unclear. Potentially this is due to
cdm-vaadin and cdmlib-webapp do not being merged correctly into a common war.
The web.xml in the resulting war file has no entry for vaadin. Has this to do with the build process when merging the two projects?

Associated revisions

Revision d0ded6af (diff)
Added by Andreas Kohlbecker over 2 years ago

ref #6206 solving problems with the war overlay and adding test dependency cdmlib-db

Revision a45e5ee7 (diff)
Added by Andreas Kohlbecker over 2 years ago

fix #6206 mapping one @WebServlets to the path /VAADIN/*

Revision 5dc7cec8 (diff)
Added by Andreas Kohlbecker over 2 years ago

ref #6206 cleaning up - removing commented section

History

#1 Updated by Patrick Plitzner over 2 years ago

  • Severity changed from normal to critical

#2 Updated by Andreas Kohlbecker over 2 years ago

  • Target version changed from Unassigned CDM tickets to Release 4.4
  • Severity changed from critical to blocker

#3 Updated by Andreas Kohlbecker over 2 years ago

  • Subject changed from Vaadin and cdmlib-webapp do not merge correctly on web.xml to Vaadin view fail with: Failed to load the bootstrap javascript
  • Description updated (diff)
  • Status changed from New to In Progress
  • Assignee changed from Patrick Plitzner to Andreas Kohlbecker

#4 Updated by Andreas Kohlbecker over 2 years ago

I examined the situation more in depth:

  1. The pom.xml in cdm-webapp was pretty much messed up in respect of the creation of the final war. This has been fixed now with cdm-webapp|d0ded6af
  2. The web.xml in the war of the release 4.3.0 also is the one from cdmlib-remote-webapp. So this is not the cause of the observed error. The whole WEB-INF folder is actually excluded from the cdm-vaadin war file. This indicates that the entries in that web.xml are not needed and might be obsolte. The book of Vaadin supports this theory: '5.9.2. Web Application Contents: web.xml .... It is not needed if you define the Vaadin servlet with the @WebServlet annotation in Servlet API 3.0.

#5 Updated by Andreas Kohlbecker over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

#6 Updated by Andreas Kohlbecker over 2 years ago

  • Assignee changed from Andreas Kohlbecker to Patrick Plitzner

Please review

#7 Updated by Patrick Plitzner over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Patrick Plitzner to Andreas Kohlbecker
  • % Done changed from 50 to 100

Vaadin works on the test server. Seems fine.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)