Project

General

Profile

bug #6099

Duration of save is increasing

Added by Katja Luther over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
cdmlib
Target version:
Start date:
09/20/2016
Due date:
% Done:

0%

Estimated time:
8.00 h
Severity:
normal
Found in Version:

Description

Hallo Andreas,

also das Speicherns dauert nach Neuanlegen einer Common names bei Hieracium immer noch unerträglich lange (von fast 1 min bis zu mehreren min, im letzteren Fall erscheint eine Fehlermeldung (s.u.) aber alles ist korrekt gespeichert) . Es scheint mir, dass es um so länger dauert, je mehr Unterarten eine Art hat, warum auch immer. z.B. Hieracium murorum subsp. medianiforme.

Beste Grüße,
Norbert

login : ki
editor version : 4.2.0
server : api.cybertaxonomy.org / cybertaxonomy.org
schema version : 4.0.0.0.201604200000
os : Windows 7 6.1 amd64
java : 1.8.0_91
org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [http://api.cybertaxonomy.org:80/cichorieae/remoting/taxonnode.service]; nested exception is org.apache.http.TruncatedChunkException: Truncated chunk ( expected size: 8192; actual size: 5476)
                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.convertHttpInvokerAccessException(HttpInvokerClientInterceptor.java:216)
                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:147)
                at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
                at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:208)
                at com.sun.proxy.$Proxy53.merge(Unknown Source)
                at eu.etaxonomy.taxeditor.editor.TaxonEditorInput.merge(TaxonEditorInput.java:458)
                at eu.etaxonomy.taxeditor.editor.MultiPageTaxonEditor.doSave(MultiPageTaxonEditor.java:147)
                at org.eclipse.ui.internal.SaveableHelper$2.run(SaveableHelper.java:151)
                at org.eclipse.ui.internal.SaveableHelper$5.run(SaveableHelper.java:277)
                at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464)
                at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372)
                at org.eclipse.jface.window.ApplicationWindow$1.run(ApplicationWindow.java:759)
                at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
                at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWindow.java:756)
                at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:2649)
                at org.eclipse.ui.internal.SaveableHelper.runProgressMonitorOperation(SaveableHelper.java:285)
                at org.eclipse.ui.internal.SaveableHelper.runProgressMonitorOperation(SaveableHelper.java:264)
                at org.eclipse.ui.internal.SaveableHelper.savePart(SaveableHelper.java:156)
                at org.eclipse.ui.internal.EditorManager.savePart(EditorManager.java:1399)
                at org.eclipse.ui.internal.WorkbenchPage.savePart(WorkbenchPage.java:3416)
                at org.eclipse.ui.internal.WorkbenchPage.saveEditor(WorkbenchPage.java:3429)
                at org.eclipse.ui.internal.handlers.SaveHandler.execute(SaveHandler.java:54)
                at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:293)
                at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
                at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
                at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:169)
                at org.eclipse.ui.internal.handlers.SlaveHandlerService.executeCommand(SlaveHandlerService.java:241)
                at org.eclipse.ui.menus.CommandContributionItem.handleWidgetSelection(CommandContributionItem.java:829)
                at org.eclipse.ui.menus.CommandContributionItem.access$19(CommandContributionItem.java:815)
                at org.eclipse.ui.menus.CommandContributionItem$5.handleEvent(CommandContributionItem.java:805)
                at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
                at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4165)
                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3754)
                at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
                at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
                at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
                at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
                at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                at java.lang.reflect.Method.invoke(Unknown Source)
                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
                at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: org.apache.http.TruncatedChunkException: Truncated chunk ( expected size: 8192; actual size: 5476)
                at org.apache.http.impl.io.ChunkedInputStream.read(ChunkedInputStream.java:200)
                at org.apache.http.impl.io.ChunkedInputStream.read(ChunkedInputStream.java:215)
                at org.apache.http.impl.io.ChunkedInputStream.close(ChunkedInputStream.java:316)
                at org.apache.http.impl.execchain.ResponseEntityProxy.streamClosed(ResponseEntityProxy.java:140)
                at org.apache.http.conn.EofSensorInputStream.checkClose(EofSensorInputStream.java:228)
                at org.apache.http.conn.EofSensorInputStream.close(EofSensorInputStream.java:174)
                at java.io.ObjectInputStream$PeekInputStream.close(Unknown Source)
                at java.io.ObjectInputStream$BlockDataInputStream.close(Unknown Source)
                at java.io.ObjectInputStream.close(Unknown Source)
                at org.springframework.remoting.httpinvoker.AbstractHttpInvokerRequestExecutor.readRemoteInvocationResult(AbstractHttpInvokerRequestExecutor.java:246)
                at org.springframework.remoting.httpinvoker.HttpComponentsHttpInvokerRequestExecutor.doExecuteRequest(HttpComponentsHttpInvokerRequestExecutor.java:232)
                at eu.etaxonomy.taxeditor.service.CdmServiceRequestExecutor.doExecuteRequest(CdmServiceRequestExecutor.java:58)
                at org.springframework.remoting.httpinvoker.AbstractHttpInvokerRequestExecutor.executeRequest(AbstractHttpInvokerRequestExecutor.java:138)
                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.executeRequest(HttpInvokerClientInterceptor.java:194)
                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.executeRequest(HttpInvokerClientInterceptor.java:176)
                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:144)
                ... 52 more

Associated revisions

Revision 08a698af (diff)
Added by Katja Luther over 2 years ago

ref #6099: removing cascading to child nodes and adapting the service and persistence layer

History

#1 Updated by Katja Luther over 2 years ago

the time consuming call is CdmStore.getService(ITaxonNodeService.class).merge(taxonNode, true);

#2 Updated by Andreas Müller over 2 years ago

  • Estimated time set to 8.00 h

#3 Updated by Katja Luther over 2 years ago

to reduce the saving time we removed the cascading to the child taxa.
please test the editor, if everything works as expected and everything is saved correctly.

#4 Updated by Katja Luther over 2 years ago

  • Assignee changed from Katja Luther to Andreas Müller

#5 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 4.4 to Release 4.5

#6 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 4.5 to Release 4.6

#7 Updated by Andreas Müller about 2 years ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Müller to Norbert Kilian
  • Target version changed from Release 4.6 to Release 4.4

Hi Norbert,

could you please check if this is fixed or at least better now. Probably it was fixed in version 4.4. already.

#8 Updated by Andreas Müller about 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Norbert Kilian to Katja Luther

Hallo ,

ich habe gerade ein paar Test gemacht und da ging das Speichern für das im Ticket genannte Taxon ganz erheblich schneller (c. 20 sec) als bei Abfassen des Tickets. So ist das also völlig OK. Danke!

Beste Grüße,
Norbert

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)