Project

General

Profile

bug #5693

Deleting a synonym only deletes the synonym relation

Added by Andreas Müller about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

50%

Severity:
normal
Found in Version:

Description

What I did:

  • I deleted a persisted synonym from synonymy of Anastraphia ilicifolia in Cuba Checklist via NameEditor

  • The synonym disappeared from the list of synonyms in NameEditor

  • Saved

  • Searched in Name Bulkeditor: Name was still there

  • Searched in Taxon Bulkeditor: Synonym was still there, only synonym relationship was missing

Expected behavior:

  • If the synonym only belongs to one synonym relationship delete the synonym itself without asking

  • (Discuss): if the related name is not used elsewhere, delete the name without asking, alternatively always use userfeedback to define the delete configuration (we may also want to have a preference for the wanted behavior), but if the synonym and the name are not yet persisted (because just entered without saving) never ask via userfeedback


Related issues

Related to Edit - bug #6219: Deleting synonym is persisted immediately, but the editor is set dirty Closed 11/24/2016

Associated revisions

Revision 08a698af (diff)
Added by Katja Luther over 2 years ago

ref #6099: removing cascading to child nodes and adapting the service and persistence layer

History

#2 Updated by Katja Luther over 2 years ago

  • Description updated (diff)
  • Status changed from New to Closed
  • Target version changed from Unassigned CDM tickets to Release 4.4

#3 Updated by Andreas Müller over 2 years ago

  • Status changed from Closed to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 0 to 50

I need to check this also against the new synonym implementation in CDM model.

#4 Updated by Andreas Müller over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther

This seems to be fixed also after model changes (removed synonym relationship class). However there are issues about the immediate saving of the synonyms in NameEditor. A new ticket will be created.

#5 Updated by Katja Luther over 2 years ago

  • Related to bug #6219: Deleting synonym is persisted immediately, but the editor is set dirty added

#6 Updated by Andreas Müller over 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)