Project

General

Profile

bug #5680

Out-of-Memory when editing TaxonInteraction

Added by Andreas Müller over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
04/13/2016
Due date:
% Done:

100%

Estimated time:
8.00 h
Severity:
major
Found in Version:
Tags:

Description

When editing TaxonInteractions in Flora of Cuba (Feature: Families in other Floras) I get a Java heap space exception

login : admin
editor version : 3.12.4
server : api.cybertaxonomy.org / cybertaxonomy.org
schema version : 3.6.0.0.201527040000
os : Windows Server 2012 6.2 amd64
java : 1.7.0_75
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.OutOfMemoryError: Java heap space)
    at org.eclipse.swt.SWT.error(SWT.java:4282)
    at org.eclipse.swt.SWT.error(SWT.java:4197)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: java.lang.OutOfMemoryError: Java heap space
    at java.util.Arrays.copyOf(Unknown Source)
    at java.lang.AbstractStringBuilder.expandCapacity(Unknown Source)
    at java.lang.AbstractStringBuilder.ensureCapacityInternal(Unknown Source)
    at java.lang.AbstractStringBuilder.append(Unknown Source)
    at java.lang.StringBuffer.append(Unknown Source)
    at java.io.StringWriter.write(Unknown Source)
    at java.io.PrintWriter.write(Unknown Source)
    at java.io.PrintWriter.write(Unknown Source)
    at java.io.PrintWriter.print(Unknown Source)
    at java.io.PrintWriter.println(Unknown Source)
    at java.lang.Throwable$WrappedPrintWriter.println(Unknown Source)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:695)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)
    at java.lang.Throwable.printEnclosedStackTrace(Throwable.java:709)

Associated revisions

Revision 4b5eb627 (diff)
Added by Katja Luther almost 3 years ago

fix #5680: get method needs to be named like the attribute

History

#1 Updated by Andreas Müller over 3 years ago

blocks #5501

#2 Updated by Andreas Müller over 3 years ago

  • Priority changed from New to Highest

#3 Updated by Katja Luther over 3 years ago

another problem with Families in other Floras:

creation of a new Families in other Floras does not show up, no exception is thrown (connected to the test server).

when connecting to a local cuba database the entry Families in other Floras appears twice in the right click menu, but it is possible to create new data.

#4 Updated by Andreas Müller over 3 years ago

  • Target version changed from Unassigned CDM tickets to Release 4.1

#5 Updated by Andreas Müller about 3 years ago

  • Target version changed from Release 4.1 to Release 4.2

#6 Updated by Andreas Müller about 3 years ago

  • Target version changed from Release 4.2 to Release 4.3

#7 Updated by Katja Luther almost 3 years ago

  • Description updated (diff)

Katja Luther wrote:

another problem with Families in other Floras:

creation of a new Families in other Floras does not show up, no exception is thrown (connected to the test server).

when connecting to a local cuba database the entry Families in other Floras appears twice in the right click menu, but it is possible to create new data.

This works now. But the original problem still exist. The problem is, that the descriptions can not be loaded.

#8 Updated by Andreas Müller almost 3 years ago

  • Target version changed from Release 4.3 to Release 4.4

#9 Updated by Andreas Müller almost 3 years ago

  • Estimated time set to 8.00 h

#10 Updated by Katja Luther almost 3 years ago

The problem was the naming of the getter method for description. It was getDescriptions() but should be getDescription().

#11 Updated by Katja Luther almost 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#12 Updated by Katja Luther almost 3 years ago

  • Assignee changed from Katja Luther to Andreas Müller

#14 Updated by Andreas Müller almost 3 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther

Seems to be fixed. There might be some other such issues. See #3841

#15 Updated by Andreas Müller almost 3 years ago

  • % Done changed from 50 to 100

#16 Updated by Andreas Müller over 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)