Project

General

Profile

Actions

bug #5477

open

lucene index not updated in all cases after Taxon.addMisappliedName

Added by Andreas Kohlbecker almost 7 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Priority14
Category:
cdmlib
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
critical
Found in Version:

Description

r27007 487070f : circumventing bug that broke test and creating new test to reproduce this issue, new test ignored:

TaxonServiceSearchTest.testFindTaxaAndNamesByFullText_AreaFilter_issue5477()

Actions #1

Updated by Andreas Kohlbecker over 6 years ago

  • Target version changed from Unassigned CDM tickets to Release 4.0
  • Priority changed from New to Highest

this has been marked as duplicate of #5442 which was in Milestone 'Release 4.0' with priority 'Highest'. Adapting this ticket accordingly.

Actions #2

Updated by Andreas Kohlbecker over 6 years ago

  • Status changed from New to In Progress
Actions #3

Updated by Andreas Müller over 6 years ago

  • Target version changed from Release 4.0 to Release 4.1
Actions #4

Updated by Andreas Müller over 6 years ago

  • Target version changed from Release 4.1 to Release 4.2
Actions #5

Updated by Andreas Müller over 6 years ago

  • Target version changed from Release 4.2 to Release 4.3
Actions #6

Updated by Andreas Müller about 6 years ago

  • Target version changed from Release 4.3 to Release 4.4
Actions #7

Updated by Andreas Kohlbecker about 6 years ago

  • Description updated (diff)
  • Target version changed from Release 4.4 to Release 4.5
Actions #8

Updated by Andreas Müller almost 6 years ago

  • Target version changed from Release 4.5 to Release 4.6
Actions #9

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.6 to Release 4.7
Actions #10

Updated by Andreas Müller over 5 years ago

  • Private changed from Yes to No
Actions #11

Updated by Andreas Kohlbecker over 5 years ago

  • Target version changed from Release 4.7 to Release 4.8
Actions #12

Updated by Andreas Kohlbecker over 5 years ago

  • Target version changed from Release 4.8 to Release 4.9
Actions #13

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.9 to Release 4.10
Actions #14

Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 4.10 to Release 4.11
Actions #15

Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 4.11 to Release 4.12
Actions #16

Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.12 to Release 4.13
Actions #17

Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.13 to Release 4.14
Actions #18

Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.14 to Release 5.0
Actions #19

Updated by Andreas Kohlbecker over 4 years ago

  • Target version changed from Release 5.0 to Release 5.1
Actions #20

Updated by Andreas Müller over 4 years ago

  • Tags changed from lucene to lucene, euro+med
  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

Seems to be fixed with using @ContainedIn on relationsToThisTaxon and relationsfromThisTaxon.

Please review.

Actions #21

Updated by Andreas Kohlbecker over 4 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

Looks good and seems to work since the test is now running successfully.

Actions #22

Updated by Andreas Kohlbecker over 4 years ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller
Actions #23

Updated by Andreas Müller 6 months ago

  • Status changed from Closed to Resolved
  • Target version changed from Release 5.1 to Release 5.32

Was not fully fixed yet. Problem reoccurred after upgrading to hibernate-search 5.7.3. "ContainedIn" was still missing on TaxonRelationship.relatedFrom and .relatedTo.

Actions #24

Updated by Andreas Müller 4 months ago

  • Target version changed from Release 5.32 to Release 5.33
Actions #25

Updated by Andreas Müller 4 months ago

  • Target version changed from Release 5.33 to Release 5.32
Actions #26

Updated by Andreas Müller 4 months ago

  • Priority changed from Highest to Priority14
Actions

Also available in: Atom PDF