Project

General

Profile

bug #5163

Converting persons to team members may result in "-empty team-"

Added by Andreas Müller over 5 years ago. Updated 5 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
08/25/2015
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

A tried to convert a person to a team, but there was no member added to the team and the title cache is only "-empty team-".

Moving links to the objects seems to work.


Related issues

Related to Edit - feature request #4769: Allow convert team to person Closed 04/01/2015
Related to Edit - feature request #4770: Allow convert person to team Closed 04/01/2015
Related to Edit - feature request #4908: adding convert Team to Person and Person to Team to the bulk editor Closed 05/18/2015
Related to Edit - feature request #9363: Allow to parse the new team when converting person to team New 12/22/2020

Associated revisions

Revision 304fcfc8 (diff)
Added by Andreas Müller 5 months ago

ref #4770, ref #4908, ref #5163 assert that team has protected nomenclatural title after convertPerson2Team

Revision 6057b354 (diff)
Added by Andreas Müller 5 months ago

ref #4770, ref #4908, ref #5163 some finetuning on convertPerson2Team

Revision f8fa7762 (diff)
Added by Andreas Müller 5 months ago

ref #4770, ref #4908, ref #5163 try to remove explicit setting of protected nomecncl. title in convertPerson2Team

Revision dc310f85 (diff)
Added by Andreas Müller 5 months ago

ref #4770, ref #4908, ref #5163 remove commented line as it seems to work now

History

#1 Updated by Katja Luther over 5 years ago

in the merge strategy the adding of the person(s) to the new created team is missing.

we need:

  • parsing the title of the old person whether there is a "&" and/or "," and creating one or more new persons

  • adding these persons to the new created team.

#2 Updated by Katja Luther over 5 years ago

maybe we should not use a merge for convertPerson2team because the new created team should have the person as a teammember, but with merge the person is deleted.

#3 Updated by Andreas Müller 5 months ago

#4 Updated by Andreas Müller 5 months ago

#5 Updated by Andreas Müller 5 months ago

  • Related to feature request #4908: adding convert Team to Person and Person to Team to the bulk editor added

#6 Updated by Andreas Müller 5 months ago

#7 Updated by Andreas Müller 5 months ago

  • Subject changed from Converting persons to team members does not work to Converting persons to team members may result in "-empty team-"
  • Description updated (diff)
  • Status changed from New to Closed
  • Assignee changed from Katja Luther to Andreas Müller
  • Target version changed from Unassigned CDM tickets to Release 5.19
  • % Done changed from 0 to 100

The "empty team" issue has been solved. The handling of team members has been moved to follow up ticket #9363 as it is not a bug but a feature that needs to be configurable.
Changing subject of this ticket to be inline with actually fixed issue.

#8 Updated by Andreas Müller 5 months ago

  • Private changed from Yes to No

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)