Project

General

Profile

bug #5095

Fix failing dozer related tests

Added by Cherian Mathew almost 6 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
07/06/2016
Due date:
% Done:

100%

Severity:
blocker
Found in Version:

Description

Dozer related tests are failing due to missing dtd file,

java.io.IOException: Server returned HTTP response code: 503 for URL: http://dozer.sourceforge.net/dtd/dozerbeanmapping.dtd

The failing tests include,

  • eu.etaxonomy.cdm.remote.dto.assembler.lsid.AssemblerTest.testSpeciesProfileModelMapping

  • eu.etaxonomy.cdm.remote.dto.assembler.lsid.AssemblerTest.testLazyInitializationExceptionWithProxy

  • eu.etaxonomy.cdm.remote.dto.assembler.lsid.AssemblerTest.testDeepMapping

  • eu.etaxonomy.cdm.remote.dto.assembler.lsid.AssemblerTest.testLazyInitializationExceptionWithPersistentCollection

  • eu.etaxonomy.cdm.remote.dto.assembler.lsid.AssemblerTest.testSimpleDarwinCoreMapping

  • eu.etaxonomy.cdm.remote.dto.assembler.lsid.AssemblerTest.testOAIDublinCoreMapping

  • eu.etaxonomy.cdm.remote.view.OaiPmhViewTest.testGetRecordView

  • eu.etaxonomy.cdm.remote.view.OaiPmhViewTest.testRdfGetRecordView

  • eu.etaxonomy.cdm.remote.view.OaiPmhViewTest.testListIdentifiersView

  • eu.etaxonomy.cdm.remote.view.OaiPmhViewTest.testListRecordsView

  • eu.etaxonomy.cdm.remote.view.RdfViewTest.testNameInformationRdf

This needs to be fixed urgently as it prevents the deployment of the cdmlib jars to the maven repository.


Related issues

Related to Edit - bug #6324: fix dozer mapping after removal of synonym relations and after using TaxonNode Closed 01/11/2017
Precedes Edit - task #7286: re-enable dozer related tests Duplicate 07/07/2016 07/07/2016

Associated revisions

Revision ad89c499 (diff)
Added by Andreas Müller 3 months ago

ref #5095 change dozer mapping from .dtd to .xsd

Revision 0b5641a3 (diff)
Added by Andreas Müller 3 months ago

ref #5095 avoid running dozer tests when dozer.sourceforge.net is not available

Revision 523a6c95 (diff)
Added by Andreas Müller 3 months ago

fix #5095 unignore tests (remaining 2 tests in AssemblerTest are caused by changes in #6324)

Revision 5db155c8 (diff)
Added by Andreas Müller 3 months ago

ref #9359, ref #5095 upgrade dozer form 5.5.1 to 6.5.0 and use dozer-spring

Revision ded02d5b (diff)
Added by Andreas Müller 3 months ago

ref #5095 fixing variable name for oahServerURI

History

#1 Updated by Cherian Mathew almost 6 years ago

Added @Ignore to the tests for now (r25125) for building the taxeditor urgently for Sabine.

#2 Updated by Andreas Kohlbecker over 5 years ago

  • Target version deleted (Release 3.8)

moving unresolved tickets to next milestone after release of 3.8.0

#3 Updated by Andreas Müller over 5 years ago

  • Target version deleted (Release 3.12)

#4 Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 4.0 to Release 4.1

#5 Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.1 to Release 4.2

#6 Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.2 to Release 4.3

#7 Updated by Andreas Müller over 4 years ago

  • Target version changed from Release 4.3 to Release 4.4

#8 Updated by Andreas Müller over 4 years ago

  • Target version changed from Release 4.4 to Release 4.5

#9 Updated by Andreas Müller over 4 years ago

  • Target version changed from Release 4.5 to Release 4.6

#10 Updated by Andreas Müller about 4 years ago

  • Target version changed from Release 4.6 to Release 4.7

#11 Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 4.7 to Release 4.8

#12 Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 4.8 to Release 4.9

#13 Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 4.9 to Release 4.10

#14 Updated by Andreas Müller over 3 years ago

  • Description updated (diff)
  • Target version changed from Release 4.10 to Release 4.12

#15 Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 4.12 to Release 4.13

#16 Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 4.13 to Release 4.14

#17 Updated by Andreas Müller about 3 years ago

  • Target version changed from Release 4.14 to Release 5.0

#18 Updated by Andreas Kohlbecker about 3 years ago

  • Precedes task #7286: re-enable dozer related tests added

#19 Updated by Andreas Kohlbecker about 3 years ago

the tests in

cdmlib-remote/src/test/java/eu/etaxonomy/cdm/remote/dto/assembler/lsid/AssemblerTest.java
cdmlib-remote/src/test/java/eu/etaxonomy/cdm/remote/view/OaiPmhViewTest.java
cdmlib-remote/src/test/java/eu/etaxonomy/cdm/remote/view/RdfViewTest.java

have been disabled.

Solve the original problem and remove all @Ignore

#20 Updated by Andreas Kohlbecker about 3 years ago

  • Private changed from Yes to No

#21 Updated by Andreas Müller almost 3 years ago

  • Target version changed from Release 5.0 to Release 5.1

#22 Updated by Andreas Müller almost 3 years ago

  • Target version changed from Release 5.1 to Release 5.2

#23 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.2 to Release 5.3

#24 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.3 to Release 5.5

#25 Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 5.5 to Release 5.6

#26 Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 5.6 to Reviewed Next Major Release

#27 Updated by Andreas Müller 9 months ago

  • Related to bug #6324: fix dozer mapping after removal of synonym relations and after using TaxonNode added

#28 Updated by Andreas Müller 3 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#29 Updated by Andreas Müller 3 months ago

  • Subject changed from URGENT : Fix failing dozer related tests to Fix failing dozer related tests
  • Assignee changed from Andreas Müller to Andreas Kohlbecker
  • Target version changed from Reviewed Next Major Release to Release 5.21

please review

#30 Updated by Andreas Kohlbecker 3 months ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • % Done changed from 50 to 100

code changes look good, test are all successful so the ticket is solved and can be closed.

I am a bit concerned though that we could run into a situation where the oai server is absent permanently (oahServerURI = new URI("http://memory.loc.gov"); <-- typo here in var name, should be oaiServerURI). The server at this URI seems to be quite old and may be replaced completely at some day?

Therefore we should consider using server mocks instead.

#31 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Closed
  • Target version changed from Release 5.21 to Release 5.20

I fixed the variable name.

http://memory.loc.gov testing is not part of this ticket therefore I close this ticket. Please open a new one if you think http://memory.loc.gov testing should be handled in a ticket.

Generally we already planned to test availability of required external services via a test not running together with cdmlib testing but separately do avoid cdmlib is failing if some service is temporarily not availabe. This still needs to be implemented.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)