Project

General

Profile

task #5085

Aggregate Distributions

Added by Günther Korb over 6 years ago. Updated 10 months ago.

Status:
In Progress
Priority:
Priority14
Category:
data
Start date:
07/14/2015
Due date:
% Done:

0%

Severity:
normal

Description

possibly this can be acomplished by making use ot the transmission engine

request: http://cdm.biodiv.naturkundemuseum-berlin.de/cdm/cdmfauneur2/description/accumulateDistributions?mode=byAreasAndRanks&targetAreaLevel=25b563b6-6a6c-401b-b090-c9498886c50b&priority=7

NOTE: This example uses TDWG3 as target area level, this might be not correct for FaunaEuropaea

this ticket is duplicated by #4469

History

#1 Updated by Günther Korb over 6 years ago

  • Status changed from New to Resolved

we started the engine with the above request

review the result

#2 Updated by Andreas Müller over 6 years ago

  • Target version set to FaunaEuropaea Migration

#3 Updated by Andreas Kohlbecker over 6 years ago

  • Keywords changed from faunaeuropaea to FaunaEuropaea

#4 Updated by Günther Korb over 6 years ago

The transmission engine is aborted with following exception

2015-07-14 10:38:29,227 INFO [eu.etaxonomy.cdm.common.monitor.DefaultProgressMonitor] - 1.0696672023437845% done (Completed Task: Accumulating distributions to super areas)
Exception in thread "Thread-57" org.hibernate.search.bridge.BridgeException: Exception while calling bridge#set
        class: eu.etaxonomy.cdm.model.description.Distribution
        path: area.area.
        at org.hibernate.search.bridge.util.impl.ContextualExceptionBridgeHelper.buildBridgeException(ContextualExceptionBridgeHelper.java:97)
        at org.hibernate.search.bridge.util.impl.ContextualExceptionBridgeHelper$OneWayConversionContextImpl.set(ContextualExceptionBridgeHelper.java:126)
        at org.hibernate.search.engine.spi.DocumentBuilderIndexedEntity.buildDocumentFields(DocumentBuilderIndexedEntity.java:510)
        at org.hibernate.search.engine.spi.DocumentBuilderIndexedEntity.buildDocumentFields(DocumentBuilderIndexedEntity.java:617)
        at org.hibernate.search.engine.spi.DocumentBuilderIndexedEntity.getDocument(DocumentBuilderIndexedEntity.java:488)
        at org.hibernate.search.engine.spi.DocumentBuilderIndexedEntity.createAddWork(DocumentBuilderIndexedEntity.java:412)
        at org.hibernate.search.engine.spi.DocumentBuilderIndexedEntity.addWorkToQueue(DocumentBuilderIndexedEntity.java:373)
        at org.hibernate.search.engine.impl.WorkPlan$PerEntityWork.enqueueLuceneWork(WorkPlan.java:507)
        at org.hibernate.search.engine.impl.WorkPlan$PerClassWork.enqueueLuceneWork(WorkPlan.java:278)
        at org.hibernate.search.engine.impl.WorkPlan.getPlannedLuceneWork(WorkPlan.java:164)
        at org.hibernate.search.backend.impl.WorkQueue.prepareWorkPlan(WorkQueue.java:137)
        at org.hibernate.search.backend.impl.BatchedQueueingProcessor.prepareWorks(BatchedQueueingProcessor.java:71)
        at org.hibernate.search.backend.impl.PostTransactionWorkQueueSynchronization.flushWorks(PostTransactionWorkQueueSynchronization.java:124)
        at org.hibernate.search.backend.impl.TransactionalWorker.flushWorks(TransactionalWorker.java:179)
        at org.hibernate.search.impl.FullTextSessionImpl.flushToIndexes(FullTextSessionImpl.java:136)
        at eu.etaxonomy.cdm.api.service.description.TransmissionEngineDistribution.flushAndClear(TransmissionEngineDistribution.java:608)
        at eu.etaxonomy.cdm.api.service.description.TransmissionEngineDistribution.accumulateByArea(TransmissionEngineDistribution.java:446)
        at eu.etaxonomy.cdm.api.service.description.TransmissionEngineDistribution.accumulate(TransmissionEngineDistribution.java:322)
        at eu.etaxonomy.cdm.remote.controller.DescriptionListController$1.run(DescriptionListController.java:158)
Caused by: org.hibernate.LazyInitializationException: could not initialize proxy - no Session
        at org.hibernate.proxy.AbstractLazyInitializer.initialize(AbstractLazyInitializer.java:164)
        at org.hibernate.proxy.AbstractLazyInitializer.getImplementation(AbstractLazyInitializer.java:285)
        at eu.etaxonomy.cdm.hibernate.HibernateProxyHelper.deproxy(HibernateProxyHelper.java:34)
        at eu.etaxonomy.cdm.model.common.CdmBase.deproxy(CdmBase.java:289)
        at eu.etaxonomy.cdm.model.common.DefinedTermBase.getPartOf(DefinedTermBase.java:249)
        at eu.etaxonomy.cdm.model.location.NamedArea.getPartOf(NamedArea.java:282)
        at eu.etaxonomy.cdm.model.location.NamedArea.getPartOf(NamedArea.java:1)
        at eu.etaxonomy.cdm.hibernate.search.DefinedTermBaseClassBridge.set(DefinedTermBaseClassBridge.java:81)
        at org.hibernate.search.bridge.util.impl.ContextualExceptionBridgeHelper$OneWayConversionContextImpl.set(ContextualExceptionBridgeHelper.java:123)
        ... 17 more

#5 Updated by Andreas Müller over 6 years ago

  • Status changed from Resolved to In Progress
  • Assignee changed from Günther Korb to Andreas Müller
  • Priority changed from New to Highest

#6 Updated by Andreas Müller over 6 years ago

  • Target version changed from FaunaEuropaea Migration to Fauna Europaea Portal Release

#7 Updated by Andreas Müller almost 6 years ago

  • Priority changed from Highest to Priority14

#8 Updated by Andreas Müller 10 months ago

  • Description updated (diff)
  • Private changed from Yes to No

This is a duplicate for some other tickets: #5176, #8679, #8677 and maybe someother.
Should be tested on FauEu Data but as FauEu is currently not active this can not be discussed with according admins.

The functionality should work now, however, the question is if we should run the it on the data and which configuration (highest rank, source handling, etc. - maybe same as for E+M?)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)