Project

General

Profile

Actions

bug #4964

closed

footnotes for taxonRelationship sources and annotations should be rendered together

Added by Andreas Kohlbecker over 7 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Priority10
Category:
cdm-dataportal
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

the ordering of the footnotes on http://dev.e-taxonomy.eu/dataportal/rotelisten_flora_deutschland/cdm_dataportal/taxon/6a24cc06-c5fc-4b29-aaea-ee21be1130a6/synonymy. is wrong. First comes 5 then 4, should be the other way round.

Please scroll to the very bottom of the page. There we have first "5. sensu Andere Referenzen (fuer auct. Synonyme)" and then "4. Homonym".

This is an effect of rendering the footnotes for taxonRelationships taxonRelationships annotations together:

<li class="footnotes footnotes-taxonRelationships "></li>
<li class="footnotes footnotes-taxonRelationships-annotations "></li>

They should be rendered together instead.

Closely related to #2602 (Taxon synonymy: type designation footnotes rendered together with taxon_page_synonymy footnotes)

ticket has been split of from #2679


Related issues

Related to EDIT - bug #2602: Taxon synonymy: type designation footnotes rendered together with taxon_page_synonymy footnotesWorksformeAndreas Kohlbecker

Actions
Is duplicate of EDIT - task #8543: overcome distinction of annotation and other foonotesClosedAndreas Kohlbecker

Actions
Actions #1

Updated by Andreas Kohlbecker over 3 years ago

  • Description updated (diff)
  • Private changed from Yes to No
Actions #2

Updated by Andreas Kohlbecker over 3 years ago

  • Related to bug #2602: Taxon synonymy: type designation footnotes rendered together with taxon_page_synonymy footnotes added
Actions #3

Updated by Andreas Kohlbecker over 3 years ago

  • Related to task #8543: overcome distinction of annotation and other foonotes added
Actions #4

Updated by Andreas Müller over 3 years ago

  • Subject changed from footnotes for taxonRelationships taxonRelationships annotations should be rendered together to footnotes for taxonRelationships annotations should be rendered together
  • Target version changed from cdm_dataportal - Next Major Release to Unassigned CDM tickets

The other milestone should not be used anymore

Actions #5

Updated by Andreas Kohlbecker over 2 years ago

can be solved by setting the $footnote_list_key_suggestion parameter of handle_annotations_and_sources() explicitly.

Here at the example of creating footnotes for typedesignations:

handle_annotations_and_sources(
          $derivedUnitFacadeInstance,
          typedesignations_annotations_and_sources_config(),
          '',
          RenderHints::getFootnoteListKey()
        );
Actions #6

Updated by Andreas Kohlbecker over 2 years ago

  • Status changed from New to Worksforme
  • Target version deleted (Unassigned CDM tickets)
Actions #7

Updated by Andreas Kohlbecker over 2 years ago

  • Status changed from Worksforme to New
  • Target version set to Unassigned CDM tickets
Actions #8

Updated by Andreas Kohlbecker over 2 years ago

  • Subject changed from footnotes for taxonRelationships annotations should be rendered together to footnotes for taxonRelationship sources and annotations should be rendered together
Actions #9

Updated by Andreas Kohlbecker over 2 years ago

  • Related to deleted (task #8543: overcome distinction of annotation and other foonotes)
Actions #10

Updated by Andreas Kohlbecker over 2 years ago

  • Is duplicate of task #8543: overcome distinction of annotation and other foonotes added
Actions #11

Updated by Andreas Kohlbecker over 2 years ago

  • Status changed from New to Duplicate
  • Target version deleted (Unassigned CDM tickets)
  • % Done changed from 0 to 100

closing as duplicate of #8543

Actions

Also available in: Atom PDF