Project

General

Profile

Actions

feature request #4867

open

Add menu item for subtree cloning

Added by Andreas Müller over 6 years ago. Updated 5 months ago.

Status:
In Progress
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
05/06/2015
Due date:
% Done:

20%

Estimated time:
Severity:
normal

Description

once #4866 is available we may need it as an menu item for classifications / subtrees in the taxon navigator.

Also implement configuration form for advanced usage with parameters (for parameters see SubtreeCloneConfigurator), but do not allow name cloning for now as it is still not fully implemented and difficult to understand.

Try to implement as long running task (the method still needs to be adopted to this - #9349)

blocked by #4866

related issues: #4864


Related issues

Related to Edit - bug #9349: Open issues for classification cloningNewAndreas Müller12/04/2020

Actions
Blocked by Edit - feature request #4866: Implement clone method for complete classificationsClosedAndreas Müller04/30/2015

Actions
Actions #1

Updated by Andreas Müller over 6 years ago

  • Assignee changed from k.luther - to Andreas Müller
  • Target version deleted ()
  • Priority changed from Priority08 to Priority13
Actions #2

Updated by Andreas Müller over 6 years ago

  • Assignee changed from Andreas Müller to k.luther -
Actions #4

Updated by Andreas Müller about 5 years ago

  • Description updated (diff)
  • Assignee changed from Katja Luther to Patrick Plitzner
  • Target version changed from Reviewed Next Major Release to Release 4.4
Actions #5

Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 4.4 to Release 4.5
Actions #6

Updated by Andreas Müller about 5 years ago

  • Status changed from New to In Progress
  • Priority changed from Priority13 to Highest
  • % Done changed from 0 to 20

This is partly done and is an experimental feature currently.

Actions #7

Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.5 to Release 4.6
Actions #8

Updated by Andreas Müller almost 5 years ago

Actions #9

Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.6 to Release 4.7
Actions #10

Updated by Andreas Müller over 4 years ago

Please define open issues

Actions #11

Updated by Andreas Müller over 4 years ago

  • Subject changed from Add clone method for classifications to Add menu item for classification cloning
Actions #12

Updated by Patrick Plitzner over 4 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

This is most probably solved depending on how the implementation in cdmlib looks like. For now, all available parameters are display in a dialog to customize the cloning operation.
@Andreas: Could you check if in cdmlib side this is finished #4866

Actions #13

Updated by Andreas Müller over 4 years ago

  • Status changed from In Progress to Resolved
  • Private changed from Yes to No
Actions #14

Updated by Andreas Müller about 1 year ago

  • Related to bug #9349: Open issues for classification cloning added
Actions #15

Updated by Andreas Müller about 1 year ago

  • Subject changed from Add menu item for classification cloning to Add menu item for subtree cloning
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • Target version changed from Release 4.7 to Release 5.19

It seems that the menu entry was removed or does not work anymore, even with experimental features being switched on.

Also the method has improved configuration now and allows running on subtrees, not only classifications. The calling method should be adapted accordingly and a configuration dialogue is needed if it does not exist yet.

Cloning names should not be supported yet as it is a complex issue and not yet fully implemented in the underlying method (see comments in #9349).

See also #9349 for further improvements in the underlying method.

Actions #16

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #17

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #18

Updated by Katja Luther 12 months ago

  • Status changed from Feedback to In Progress
  • Target version changed from Release 5.19 to Release 5.21
Actions #19

Updated by Katja Luther 10 months ago

  • Target version changed from Release 5.21 to Release 5.22
Actions #20

Updated by Katja Luther 9 months ago

  • Target version changed from Release 5.22 to Release 5.29
Actions #21

Updated by Katja Luther 5 months ago

This is operation does not work at all at the moment, the following exception appears:

last remote method : http://localhost:8080/remoting/classification.service
last remote request client time : 2021-08-10T11:55:32.65
client error time : 2021-08-10T11:55:32.802
login : admin
editor version : 5.27.0.qualifier
server : localhost (localhost-dev)
schema version : 5.25.1.0.20210702
os : Windows 7 6.1 amd64
java : 1.8.0_92
org.eclipse.e4.core.di.InjectionException: org.eclipse.core.runtime.AssertionFailedException: null argument:getControl() of wizard page returns null. Did you call setControl() in your wizard page?
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: org.eclipse.core.runtime.AssertionFailedException: null argument:getControl() of wizard page returns null. Did you call setControl() in your wizard page?
    at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:85)
    at org.eclipse.jface.wizard.Wizard.createPageControls(Wizard.java:179)
    at org.eclipse.jface.wizard.WizardDialog.createPageControls(WizardDialog.java:696)
    at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:588)
    at org.eclipse.jface.window.Window.create(Window.java:426)
    at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1095)
    at org.eclipse.jface.window.Window.open(Window.java:783)
    at eu.etaxonomy.taxeditor.navigation.navigator.e4.handler.CloneClassificationHandlerE4.execute(CloneClassificationHandlerE4.java:59)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 37 more

Actions

Also available in: Atom PDF