Project

General

Profile

bug #4377

LazyInitializationException (LIE) related to Team.teamMembers when calling portal/taxon.json

Added by Andreas Kohlbecker over 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib-remote
Target version:
Start date:
08/28/2014
Due date:
% Done:

50%

Severity:
normal
Found in Version:

Description

http://160.45.63.175/cdmserver/palmae/portal/taxon.json

request from duplicate issue:

http://api.cybertaxonomy.org/salvador/portal/taxon/find.json?doTaxaByCommonNames=1&doMisappliedNames=1&doSynonyms=1&doTaxa=1&pageNumber=0&pageSize=25&query=Tecoma&tree=b010c84d-6049-45f4-9f13-c065101eaa26

net.sf.json.JSONException: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.agent.Team.teamMembers, could not initialize proxy - no Session
    at net.sf.json.JSONObject._fromBean(JSONObject.java:692)
    at net.sf.json.JSONObject.fromObject(JSONObject.java:172)
    at eu.etaxonomy.cdm.remote.json.processor.bean.HibernateProxyBeanProcessor.processBean(HibernateProxyBeanProcessor.java:31)
    at net.sf.json.JSONObject._fromBean(JSONObject.java:676)
    at net.sf.json.JSONObject.fromObject(JSONObject.java:172)
    at net.sf.json.AbstractJSON._processValue(AbstractJSON.java:274)
    at net.sf.json.JSONObject._processValue(JSONObject.java:2655)

Related issues

Related to Edit - bug #6317: LIE during request to portal/taxon/find.json Closed 01/09/2017

Associated revisions

Revision 8e6fba80 (diff)
Added by Andreas Kohlbecker almost 2 years ago

fix #4377 adding missing bean init path missing after ref #5974

History

#1 Updated by Andreas Kohlbecker over 3 years ago

  • Target version changed from cdmlib RELEASE 3.5.0 to cdmlib RELEASE 3.5.1

moving tickets to next milestone

#2 Updated by Andreas Müller over 3 years ago

  • Target version changed from cdmlib RELEASE 3.5.1 to cdmlib RELEASE 3.5.2

move open 3.5.1 tickets to next milestone after release

#3 Updated by Andreas Müller almost 3 years ago

  • Target version changed from cdmlib RELEASE 3.5.2 to Unassigned CDM tickets

#4 Updated by Andreas Kohlbecker almost 2 years ago

  • Description updated (diff)

Potentially a duplicate of #6317

#5 Updated by Andreas Kohlbecker almost 2 years ago

  • Related to bug #6317: LIE during request to portal/taxon/find.json added

#6 Updated by Andreas Kohlbecker almost 2 years ago

  • Target version changed from Unassigned CDM tickets to Release 4.5

#7 Updated by Andreas Kohlbecker almost 2 years ago

  • Priority changed from New to Highest

#8 Updated by Andreas Kohlbecker almost 2 years ago

  • Private changed from Yes to No

#9 Updated by Andreas Kohlbecker almost 2 years ago

  • Subject changed from LazyInitializationException related to Team.teamMembers when calling portal/taxon.json to LazyInitializationException (LIE) related to Team.teamMembers when calling portal/taxon.json

#10 Updated by Andreas Kohlbecker almost 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#11 Updated by Andreas Kohlbecker almost 2 years ago

  • Description updated (diff)

#12 Updated by Andreas Kohlbecker almost 2 years ago

  • Related to deleted (bug #6317: LIE during request to portal/taxon/find.json)

#13 Updated by Andreas Kohlbecker almost 2 years ago

  • Duplicated by bug #6317: LIE during request to portal/taxon/find.json added

#14 Updated by Andreas Kohlbecker almost 2 years ago

  • Duplicated by deleted (bug #6317: LIE during request to portal/taxon/find.json)

#15 Updated by Andreas Kohlbecker almost 2 years ago

  • Related to bug #6317: LIE during request to portal/taxon/find.json added

#16 Updated by Andreas Kohlbecker almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)