Project

General

Profile

bug #4300

Authority form does not work under Windows

Added by Andreas Müller almost 6 years ago. Updated about 1 month ago.

Status:
Worksforme
Priority:
Highest
Category:
taxeditor
Target version:
-
Start date:
08/05/2014
Due date:
% Done:

0%

Severity:
blocker
Found in Version:

Description

Except for the Delete button and the Operation Checkboxes the Authority Form does not work on Windows

History

#1 Updated by Andreas Müller almost 6 years ago

  • Severity changed from normal to critical
  • Tracker changed from feature request to bug

#2 Updated by Andreas Müller almost 6 years ago

  • Severity changed from critical to blocker

#3 Updated by Cherian Mathew almost 6 years ago

The problem is also seen under Linux and stems from the recent change in r21124. where the selection behaviour in the taxon navigator has been updated from double click to single click for opening a taxon editor.

This move to single click (selection changed) disrupts the drag & drop to the new Authority form since the opening of the taxon editor is triggered at drag start which brings the editor in focus and prevents the user from completing the drop.

Reverting the change solves the problem, but the change has not been committed yet since we are not sure why the change was done (awaiting reply from Katja).

#4 Updated by Cherian Mathew almost 6 years ago

fix committed in r21422

#5 Updated by Andreas Müller almost 6 years ago

The reason why single click was used was a requirement from the Red List Project. Florian realized that new users sometimes click only once on a taxon in the navigator and then do not understand how to continue as nothing happens.

But he agrees to change back to double click for the above reasons.

#6 Updated by Andreas Müller 3 months ago

  • Description updated (diff)
  • Status changed from New to Feedback
  • Assignee changed from Cherian Mathew to Andreas Kohlbecker
  • Target version changed from 120 to Release 5.15
  • Private changed from Yes to No

To me it looks like this ticket can be closed as worksforme even if the authority form is still not working very well, but this is another issue.

AK and KL, can you please veryfy and change status and target version if checked?

#7 Updated by Andreas Müller 3 months ago

  • Tags set to security, permission

#9 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from Feedback to Worksforme
  • Priority changed from New to Highest
  • Target version deleted (Release 5.15)

Operation Checkboxes in the Authority Form do now work in windows 10.

I have no idea how and when this was fixed, so I can't reference another ticket or a change set.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)