Project

General

Profile

Actions

bug #3933

closed

the search result list should contain bastards in alphabetical order

Added by Katja Luther about 9 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Priority13
Category:
cdmlib
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Severity:
normal
Found in Version:

Description

mail von Ralf:

Hat ein Bastard noch kein gültiges Binom, gebe ich die Bastardformel ein. So weit, so gut, aber bei den Search results landen all diese Formelnamen immer noch ganz oben in der Liste. Bei Ophrys muss man sich erst durch einen Wust dieser wichtigen, aber nicht prioritär wichtigen Namen blättern. Die Bastardformeln sollten nach Möglichkeit streng alphabetisch einsortiert werden, so dass bei Ophrys oben auf der Liste "Ophrys" steht.


Related issues

Related to EDIT - bug #5832: It is not possible to search for hybrids in taxon searchNewKatja Luther

Actions
Is duplicate of EDIT - bug #4796: Sorting of hybridsNewAndreas Müller

Actions
Actions #1

Updated by Katja Luther about 9 years ago

the order of search results is based on the atomised data, names with a bastard formula are not atomised therefore the fields are empty and they occur at the beginning of the list.

Actions #2

Updated by Andreas Müller about 9 years ago

Replying to k.luther:

the order of search results is based on the atomised data, names with a bastard formula are not atomised therefore the fields are empty and they occur at the beginning of the list.

In case genus, specific epithet, rank and nameCache are all empty we should use the titleCache as final ordering field. Otherwise all unparsed names will not be ordered correctly.

Actions #3

Updated by Andreas Müller over 1 year ago

  • Tags set to search, hybrid-taxa
  • Description updated (diff)
  • Assignee changed from Katja Luther to Andreas Müller
  • Target version changed from cdmlib - Old Next Major Release to Release 5.37
  • Private changed from Yes to No

Need to check if this is still the case. If yes, try to implement correctly.

Actions #4

Updated by Andreas Müller over 1 year ago

  • Related to bug #5832: It is not possible to search for hybrids in taxon search added
Actions #5

Updated by Andreas Müller over 1 year ago

  • Is duplicate of bug #4796: Sorting of hybrids added
Actions #6

Updated by Andreas Müller over 1 year ago

  • Status changed from New to Duplicate
  • Target version deleted (Release 5.37)

I close this as duplicate for #4796

Actions

Also available in: Atom PDF