Project

General

Profile

bug #3866

Link Taxon Editor name to the taxon in the taxon navigator

Added by Cherian Mathew about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
11/20/2013
Due date:
% Done:

100%

Estimated time:
20.00 h
Severity:
critical
Found in Version:

Description

Clicking the taxon in the editor should expand to the corresponding taxon node when the "Link with Editor" option of the Classification view is enabled.


Related issues

Related to Edit - feature request #5334: reimplement the taxonnavigator to allow drag & drop between two nodes New 10/15/2015

Associated revisions

Revision bfff18ea (diff)
Added by Patrick Plitzner over 1 year ago

ref #3866 Fix instanceOf check for classification taxon nodes

Revision f6124bb9 (diff)
Added by Patrick Plitzner over 1 year ago

ref #3866 Fix instanceOf check for classification taxon nodes

Revision 38ad71f9 (diff)
Added by Katja Luther over 1 year ago

ref #3866: adapt deleteHandler to taxonNavigatot changes

Revision bcc55cf4 (diff)
Added by Katja Luther over 1 year ago

ref #3866: adapt deleteHandler to taxonNavigatot changes

History

#1 Updated by Patrick Plitzner about 5 years ago

Another issue: the state of the "Link with editor"-button is not saved. Initially it is always turned off.

#2 Updated by Patrick Plitzner about 5 years ago

additional comment on #3895:

What I found out so far is that a taxon node is only expanded for an active editor if two requirements are met (maybe a default behavior):

  1. The classification has to be expanded.

  2. The parent node has to be visible in the tree.

#3 Updated by Andreas Müller about 5 years ago

  • Assignee changed from Andreas Kohlbecker to c.mathew -
  • Category changed from platform to taxeditor

#4 Updated by Andreas Müller about 5 years ago

  • Tracker changed from feature request to bug

#5 Updated by Andreas Müller over 4 years ago

  • Target version changed from Post Edit Workshop 2013 to TaxEditor Next Major Release
  • Priority changed from Priority08 to Priority13
  • Severity changed from normal to critical

#6 Updated by Andreas Kohlbecker over 3 years ago

this is as really annoying bug, so I am voting for solving this bug quite soon.

#7 Updated by Andreas Müller over 3 years ago

  • Target version changed from TaxEditor Next Major Release to Unassigned CDM tickets
  • Priority changed from Priority13 to Highest

I agree

#8 Updated by Andreas Müller about 2 years ago

  • Description updated (diff)
  • Assignee changed from Cherian Mathew to Katja Luther
  • Target version changed from Unassigned CDM tickets to Release 4.5

#9 Updated by Andreas Müller about 2 years ago

  • Related to feature request #5334: reimplement the taxonnavigator to allow drag & drop between two nodes added

#10 Updated by Andreas Müller about 2 years ago

  • Estimated time set to 20.00 h

#11 Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 4.5 to Release 4.6

#12 Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 4.6 to Release 4.7

#13 Updated by Katja Luther over 1 year ago

  • Status changed from New to In Progress

the problem is that the navigator starts with only the classification loaded. Maybe we need to overwrite the link method and use the treeindex.

#14 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 4.7 to Release 4.8

#15 Updated by Katja Luther over 1 year ago

Hallo,

ich habe mich gestern mit dem Problem beschäftigt, dass beim TaxonNavigator zunächst das verlinken mit dem geöffneten NameEditor bicht funktioniert. Erst wenn der Baum aufgeklappt ist. Das Problem könnte gelöst werden, wenn man die erste Ebene der Knoten schon direkt öffnet. Bei „normalen“ Klassifikationen mit Familien und Gattungen klappt das auch ganz gut, aber bei Datenbanken wie cdm_rl_plantae, in der die Arten direkt unter der Klassifikation hängen, dauert das Laden ewig.

Dies könnte man lösen, indem man eine Preference definiert, die das Aufklappen bei solchen DB abschaltet oder man zählt die Kinder der Klassifikationen und ab einer bestimmten Anzahl lässt man die Klassifikationen unaufgeklappt.

Was meint ihr?

Viele Grüße,
Katja

#16 Updated by Andreas Kohlbecker over 1 year ago

Katja Luther wrote:

Hallo Katja,

Das Problem könnte gelöst werden, wenn man die erste Ebene der Knoten schon direkt öffnet.

Das funktioniert nicht in allen Fällen, wenn ich mich recht erinnere muss man bei Projekten die tiefe Bäume haben, wie Euro+Med zum Beispiel, sich oft über mehrere Rangstufen in den Baum hineinklicken, bis das entsprechende Taxon in Reichweite kommt, so dass das 'Linken' funktioniert.

Mein Ansatz zur Lösung dieses Tickets wäre folgende Strategie in den TaxonNavigator zu implementieren:

  1. TaxonNavigator versucht sich mit dem aktiven EditorView zu sychronisieren
  2. Falls dies nicht erfolgreich ist, eine Suche nach dem entsprechenden TaxonNode ausführen
  3. wurde der Node gefunden per ClassificationService den "path to root" des TaxonNodes holen und entlang dieses Pfades alle Knoten aufklappen.
  4. Nochmals die Synchronisierung ausführen.

Dies könnte man lösen, indem man eine Preference definiert, die das Aufklappen bei solchen DB abschaltet oder man zählt die Kinder der Klassifikationen und ab einer bestimmten Anzahl lässt man die Klassifikationen unaufgeklappt.

Besser wäre es nur die TaxonNodes zu laden die im aktuellen Viewport sichtbar sind und beim Scrollen nachladen.

Andreas

#17 Updated by Andreas Müller over 1 year ago

  • Private changed from Yes to No

#18 Updated by Katja Luther over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

please review.

#19 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 100

This really works. Great!

Only minor issue: the performance might be slow especially when opening a taxon with a large synonymy and deep in the tree. Maybe in future we may find a way to load this asynchronously.
But I think we can close this ticket now!

#20 Updated by Andreas Müller about 1 year ago

I tested with a new opened E+M database for Calendula arvensis which has about 10 ancestors.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)